summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-09-09 21:50:40 +0200
committerM0Rf302019-09-09 21:50:40 +0200
commit0d58e4108f6b3f051a811e58455e662f978a510c (patch)
tree35cdbcb9dd1954c15e0dba7455570abce001f5d6
parentae6628cbea935c5f61215b66d22d9c160c370456 (diff)
downloadaur-0d58e4108f6b3f051a811e58455e662f978a510c.tar.gz
lollypop-git: updated
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c49ca8259fe..22426db34eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lollypop-git
pkgdesc = Music player for GNOME
- pkgver = 0.9.923.r101.g621df9b7
+ pkgver = 1.1.4.2.r1073.gb91d490c
pkgrel = 1
url = https://gitlab.gnome.org/gnumdk/lollypop
arch = any
@@ -10,16 +10,15 @@ pkgbase = lollypop-git
makedepends = intltool
makedepends = itstool
makedepends = meson
+ depends = appstream-glib
depends = gst-plugins-base-libs
depends = gtk3
depends = python-beautifulsoup4
depends = python-cairo
- depends = python-dbus
depends = python-gobject
depends = python-pillow
depends = totem-plparser
optdepends = easytag: Modify tags
- optdepends = flatpak: Flatpak Portal
optdepends = gst-libav: FFmpeg plugin for GStreamer
optdepends = gst-plugins-bad: "Bad" plugin libraries
optdepends = gst-plugins-base: "Base" plugin libraries
@@ -28,7 +27,7 @@ pkgbase = lollypop-git
optdepends = kid3-qt: Store covers in tags
optdepends = libsecret: Last.FM support
optdepends = python-pylast: Last.FM support
- optdepends = python-wikipedia: Wikipedia support
+ optdepends = youtube-dl: Youtube support
provides = lollypop
conflicts = lollypop
source = git+https://gitlab.gnome.org/World/lollypop
diff --git a/PKGBUILD b/PKGBUILD
index 489334965255..6049970f6d24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# Contributor: Ian Brunelli (brunelli) <ian@brunelli.me>
pkgname=lollypop-git
-pkgver=0.9.923.r101.g621df9b7
+pkgver=1.1.4.2.r1073.gb91d490c
pkgrel=1
pkgdesc='Music player for GNOME'
arch=(any)
url=https://gitlab.gnome.org/gnumdk/lollypop
license=(GPL)
depends=(
+ appstream-glib
gst-plugins-base-libs
gtk3
python-beautifulsoup4
python-cairo
- python-dbus
python-gobject
python-pillow
totem-plparser
@@ -29,7 +29,6 @@ makedepends=(
)
optdepends=(
'easytag: Modify tags'
- 'flatpak: Flatpak Portal'
'gst-libav: FFmpeg plugin for GStreamer'
'gst-plugins-bad: "Bad" plugin libraries'
'gst-plugins-base: "Base" plugin libraries'
@@ -38,7 +37,7 @@ optdepends=(
'kid3-qt: Store covers in tags'
'libsecret: Last.FM support'
'python-pylast: Last.FM support'
- 'python-wikipedia: Wikipedia support'
+ 'youtube-dl: Youtube support'
)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -48,12 +47,12 @@ pkgver() {
cd "$srcdir/${pkgname%-git}"
git describe --tags \
- | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
arch-meson lollypop build \
- --libexecdir='lib/lollypop'
+ --libexecdir='lib/lollypop'
ninja -C build
}