summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:46:57 +0800
committerSainnhepark2020-07-28 16:46:57 +0800
commit0d8d31eae47e4ddfbaf8c5b37ec50dac49d2e210 (patch)
tree1d7d69ddeeee5174c3928836c37d374a62df2a43
parent23b73728481b7775373aa24f208d3dc6fe94ed71 (diff)
downloadaur-0d8d31eae47e4ddfbaf8c5b37ec50dac49d2e210.tar.gz
update build()
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35afa6909588..80a30905b339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}