summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis Mosāns2023-02-13 00:38:47 +0000
committerDāvis Mosāns2023-02-13 00:38:47 +0000
commit0da96287bdefaab05d06663e1df005cf9cf4120e (patch)
tree140e91b6dd8c350b7ff53cbedc94a999ec72c266
parenta8522102ba8c5631957b75859e93f75d7becc2b8 (diff)
downloadaur-0da96287bdefaab05d06663e1df005cf9cf4120e.tar.gz
Fix kF6 build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rwxr-xr-xport_kf6.sh16
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9730d63271..fdcd3ef4cd5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = baloo-widgets-git
pkgdesc = Widgets for Baloo (Git)
- pkgver = 22.12.0.r20.gf00fb2d
+ pkgver = 22.12.0.r22.g2c05adc
pkgrel = 1
url = https://community.kde.org/Baloo
arch = i686
@@ -13,6 +13,8 @@ pkgbase = baloo-widgets-git
provides = baloo-widgets
conflicts = baloo-widgets
source = git+https://invent.kde.org/libraries/baloo-widgets.git
+ source = port_kf6.sh
+ md5sums = SKIP
md5sums = SKIP
pkgname = baloo-widgets-git
diff --git a/PKGBUILD b/PKGBUILD
index cf895cfec642..0df2670e07ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=baloo-widgets-git
-pkgver=22.12.0.r20.gf00fb2d
+pkgver=22.12.0.r22.g2c05adc
pkgrel=1
pkgdesc='Widgets for Baloo (Git)'
arch=(i686 x86_64)
@@ -13,16 +13,17 @@ depends=(baloo-git)
makedepends=(extra-cmake-modules git kdoctools)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=(git+https://invent.kde.org/libraries/baloo-widgets.git)
-md5sums=('SKIP')
+source=(git+https://invent.kde.org/libraries/baloo-widgets.git port_kf6.sh)
+md5sums=('SKIP' 'SKIP')
pkgver() {
git -C "${pkgname%-git}" describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
+ cd "${pkgname%-git}" && "$srcdir/port_kf6.sh" && cd "$srcdir"
cmake -B build -S "${pkgname%-git}" \
- -DQT_MAJOR_VERSION=6
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}
diff --git a/port_kf6.sh b/port_kf6.sh
new file mode 100755
index 000000000000..939f66da223e
--- /dev/null
+++ b/port_kf6.sh
@@ -0,0 +1,16 @@
+#!/usr/bin/env sh
+
+find -type f \( -name 'CMakeLists.txt' -o -iname '*.cmake' -o -iname '*.cmake.in' -o -iname '*.pc.in' \) -print0 | xargs -0 sed -i 's/Qt5/Qt6/g'
+find -type f \( -name 'CMakeLists.txt' -o -iname '*.cmake' -o -iname '*.cmake.in' -o -iname '*.pc.in' \) -print0 | xargs -0 sed -i 's/KF5/KF6/g'
+find -type f \( -name 'CMakeLists.txt' -o -iname '*.cmake' -o -iname '*.cmake.in' -o -iname '*.sh' -o -iname '*.md' -o -iname '*.categories' -o -iname '*.json' -o -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/kf5/kf6/g'
+find -type f \( -name 'CMakeLists.txt' -o -iname '*.cmake' -o -iname '*.pc.in' -o -iname '*.sh' -o -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/kde5/kde6/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/_KF5/_KF6/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/Plasma::AbstractRunner/KRunner::AbstractRunner/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/Plasma::QueryMatch/KRunner::QueryMatch/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/Plasma::RunnerContext/KRunner::RunnerContext/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/Plasma::RunnerManager/KRunner::RunnerManager/g'
+find -type f \( -iname '*.h' -o -iname '*.cpp' \) -print0 | xargs -0 sed -i 's/Plasma::RunnerSyntax/KRunner::RunnerSyntax/g'
+find ! -path '*.git*' -type f -name '*KF5*' -print0 | xargs -0 -r rename 'KF5' 'KF6'
+find ! -path '*.git*' -type f -name 'kf5*' -print0 | xargs -0 -r rename 'kf5' 'kf6'
+find ! -path '*.git*' -type f -name 'kde5*' -print0 | xargs -0 -r rename 'kde5' 'kde6'
+