summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2018-02-17 10:54:30 -0800
committerPatrick McCarty2018-02-17 10:54:30 -0800
commit0dc65895eab13b2ea6806cee391ed6ddc602756f (patch)
treecc2760c5f789eae4db03dbc2cec88e5fe32425e3
downloadaur-0dc65895eab13b2ea6806cee391ed6ddc602756f.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ead6bdf66a7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Feb 17 18:53:22 UTC 2018
+pkgbase = gawk-abort
+ pkgdesc = GAWK extension - implements the abort API
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/gawkextlib/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gawkextlib
+ source = https://downloads.sourceforge.net/gawkextlib/gawk-abort-1.0.1.tar.gz
+ md5sums = 6b5a723a98b76c0197e026aab68534eb
+ sha256sums = 61a007421159607131d0b7d730948b696db2d03694bac40eb54265a5c9c023b5
+
+pkgname = gawk-abort
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2b022307d03e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58622d9adf86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=gawk-abort
+_project=gawkextlib
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="GAWK extension - implements the abort API"
+arch=('i686' 'x86_64')
+url="https://sourceforge.net/projects/gawkextlib/"
+license=('GPL')
+makedepends=('gawkextlib')
+source=("https://downloads.sourceforge.net/$_project/$pkgname-$pkgver.tar.gz")
+md5sums=('6b5a723a98b76c0197e026aab68534eb')
+sha256sums=('61a007421159607131d0b7d730948b696db2d03694bac40eb54265a5c9c023b5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}