summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-12-19 12:17:28 +0100
committerPhilipp A2021-12-19 12:17:28 +0100
commit0ddcb2304b89e158056b0f2fdb268f8baaa1eda7 (patch)
treeb7a4e1f7c1e2b7fe90a790bb830c3c8f0b24cf52
parentcbb7c706383c594a462a3e6a05d4b3d615f2312c (diff)
downloadaur-0ddcb2304b89e158056b0f2fdb268f8baaa1eda7.tar.gz
Fixed build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8731070d8aa..821b08bbbbe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-tikzplotlib-git
pkgdesc = Convert matplotlib figures into TikZ/PGFPlots
- pkgver = 0.9.1.r5.gd9f636f
+ pkgver = 0.9.16.r2.g1e30229
pkgrel = 1
url = https://github.com/nschloe/tikzplotlib
arch = any
license = MIT
- makedepends = python
+ makedepends = python-build
depends = python
- depends = python-numpy
depends = python-matplotlib
+ depends = python-numpy
depends = python-pillow
conflicts = python-matplotlib2tikz
replaces = python-matplotlib2tikz
@@ -16,4 +16,3 @@ pkgbase = python-tikzplotlib-git
sha256sums = SKIP
pkgname = python-tikzplotlib-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a3571f8a9348..78ede8c9c870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=python-tikzplotlib-git
-pkgver=0.9.1.r5.gd9f636f
+pkgver=0.9.16.r2.g1e30229
pkgrel=1
pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
url="https://github.com/nschloe/tikzplotlib"
-makedepends=('python')
-depends=('python' 'python-numpy' 'python-matplotlib' 'python-pillow')
+makedepends=(python-build)
+depends=(python python-matplotlib python-numpy python-pillow)
replaces=('python-matplotlib2tikz')
conflicts=('python-matplotlib2tikz')
license=('MIT')
@@ -14,17 +14,21 @@ source=("tikzplotlib::git+https://github.com/nschloe/tikzplotlib.git")
sha256sums=('SKIP')
pkgver() {
- cd tikzplotlib
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/tikzplotlib"
+ git describe --long --tags | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {
- cd "$srcdir/tikzplotlib"
- python setup.py build
+ cd "$srcdir/tikzplotlib"
+ python -m build
}
package() {
- cd "$srcdir/tikzplotlib"
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+
+ cd "$srcdir/tikzplotlib"
+ local cleanver="$(git describe --tags --abbrev=0 | sed 's/^v//')"
+ unzip "dist/tikzplotlib-$cleanver-py3-none-any.whl" -d "$site"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}