summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Blaicher2015-10-24 17:04:56 +0200
committerMatthias Blaicher2015-10-24 17:04:56 +0200
commit0e0a65dc95af1a768df0bb169e8bcb8c5436c212 (patch)
tree67783b0c176a5b34b1c36fd06a71926193b5e221
downloadaur-0e0a65dc95af1a768df0bb169e8bcb8c5436c212.tar.gz
First release
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD83
-rw-r--r--lasercalc-git.desktop11
-rw-r--r--lasercalc-git.install11
-rw-r--r--patch_lasercalc.patch17
-rw-r--r--patch_plot.patch29
-rw-r--r--patch_properties.patch24
-rw-r--r--patch_saf.patch22
9 files changed, 237 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b70f466833c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = lasercalc-git
+ pkgdesc = A tool to calculate optical paths and resonators based on Gaussian beam matrix optics
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://sourceforge.net/apps/phpwebsite/lasercalc/
+ install = lasercalc-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = wxgtk
+ depends = wxgtk
+ conflicts = lasercalc
+ source = git+git://git.code.sf.net/p/lasercalc/code
+ source = git+git://git.code.sf.net/p/lasercalc/libproperties
+ source = git+git://git.code.sf.net/p/lasercalc/libsaf
+ source = git+git://git.code.sf.net/p/lasercalc/libplot
+ source = lasercalc-git.desktop
+ source = patch_properties.patch
+ source = patch_saf.patch
+ source = patch_plot.patch
+ source = patch_lasercalc.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = dc3d1436285e80acdd218ae09cb70354c88a62cfd6d7113f4e43bdf2297e211a8256af2a3302e132a5c1c6e1c7dc78499bc18589c377fbce939a660448a11f64
+ sha512sums = 6c8c534c65fddf5c39944817b6c5c1a0c446433691fc7d723ad52a9005d57089137ba5b1d735d9199eadcd3bc14aafcb16c6606f5610c4d0862c9264d633c407
+ sha512sums = 8cb2bb779925a8492e7595097e369621a47b0b0cf4531e96fec9280a1058a0f941bb3887bfc3170d11c8649e530693b462dd3cbbc28249251cc1b40d74102ccc
+ sha512sums = 4942dec7eacb1de18c8428838be1dc50334f4b290b518981c262b30b0358aaca1ad6271f43b039ca6de48c9c1d76de42444865216ce0e1bc8108c1d8616db44c
+ sha512sums = 5ff06762ecd9655e015a60cd91d145557e7dd6e10cdae39a365b0fcbdd3db375c54a2d7c6633349fd6130f83ed59e45c91efdf24aaa0f9e296c61ae3c0442d9c
+
+pkgname = lasercalc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16962e4591e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+code
+*.pkg.tar.xz
+libplot
+libproperties
+libsaf
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc0460ab7cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Contributor: Anton Leontiev <unsector /at/ km.ru>
+pkgname=lasercalc-git
+pkgver=0.6
+pkgrel=1
+pkgdesc='A tool to calculate optical paths and resonators based on Gaussian beam matrix optics'
+arch=('i686' 'x86_64')
+url='https://sourceforge.net/apps/phpwebsite/lasercalc/'
+license=('GPL3')
+depends=('wxgtk')
+makedepends=('wxgtk')
+conflicts=('lasercalc')
+install=$pkgname.install
+source=("git+git://git.code.sf.net/p/lasercalc/code"
+ "git+git://git.code.sf.net/p/lasercalc/libproperties"
+ "git+git://git.code.sf.net/p/lasercalc/libsaf"
+ "git+git://git.code.sf.net/p/lasercalc/libplot"
+ "$pkgname.desktop"
+
+ "patch_properties.patch"
+ "patch_saf.patch"
+ "patch_plot.patch"
+ "patch_lasercalc.patch")
+
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'dc3d1436285e80acdd218ae09cb70354c88a62cfd6d7113f4e43bdf2297e211a8256af2a3302e132a5c1c6e1c7dc78499bc18589c377fbce939a660448a11f64'
+ '6c8c534c65fddf5c39944817b6c5c1a0c446433691fc7d723ad52a9005d57089137ba5b1d735d9199eadcd3bc14aafcb16c6606f5610c4d0862c9264d633c407'
+ '8cb2bb779925a8492e7595097e369621a47b0b0cf4531e96fec9280a1058a0f941bb3887bfc3170d11c8649e530693b462dd3cbbc28249251cc1b40d74102ccc'
+ '4942dec7eacb1de18c8428838be1dc50334f4b290b518981c262b30b0358aaca1ad6271f43b039ca6de48c9c1d76de42444865216ce0e1bc8108c1d8616db44c'
+ '5ff06762ecd9655e015a60cd91d145557e7dd6e10cdae39a365b0fcbdd3db375c54a2d7c6633349fd6130f83ed59e45c91efdf24aaa0f9e296c61ae3c0442d9c')
+
+prepare() {
+ cd "$srcdir/libproperties/properties"
+ git apply "$srcdir/patch_properties.patch"
+
+ cd "$srcdir/libsaf/SAF"
+ git apply "$srcdir/patch_saf.patch"
+
+ cd "$srcdir/libplot/plot"
+ git apply "$srcdir/patch_plot.patch"
+
+ cd "$srcdir/code/LaserCalc"
+ git apply "$srcdir/patch_lasercalc.patch"
+}
+
+build() {
+ export CPPFLAGS="-I$srcdir/libs/include"
+ export LDFLAGS="-L$srcdir/libs/lib"
+
+ msg2 "Building libproperties..."
+ cd "$srcdir/libproperties/properties"
+ rm missing; autoreconf -i
+ ./configure --prefix="$srcdir/libs" --with-wx-config=wx-config --disable-shared
+ make install
+
+ msg2 "Building libsaf..."
+ cd "$srcdir/libsaf/SAF"
+ rm missing; autoreconf -i
+ ./configure --prefix="$srcdir/libs" --with-wx-config=wx-config --disable-shared
+ make install
+
+ msg2 "Building libplot..."
+ cd "$srcdir/libplot/plot"
+ rm missing; autoreconf -i
+ ./configure --prefix="$srcdir/libs" --with-wx-config=wx-config --disable-shared
+ make install
+
+ msg2 "Building LaserCalc..."
+ cd "$srcdir/code/LaserCalc"
+ rm missing; autoreconf -i
+ ./configure --prefix=/usr --with-wx-config=wx-config
+ make
+}
+
+package() {
+ cd "$srcdir/code/LaserCalc"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir/usr/share/title.htm"
+ install -Dm644 src/lasercalc.xpm "$pkgdir/usr/share/pixmaps/lasercalc.xpm"
+ install -Dm644 "$srcdir/lasercalc-git.desktop" "$pkgdir/usr/share/applications/lasercalc-git.desktop"
+}
diff --git a/lasercalc-git.desktop b/lasercalc-git.desktop
new file mode 100644
index 000000000000..cf7ffd1123c9
--- /dev/null
+++ b/lasercalc-git.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=LaserCalc
+GenericName=LaserCalc
+Exec=lasercalc
+Icon=lasercalc
+StartupNotify=false
+Terminal=false
+Categories=Physics;Education;Science
+Comment=Optics Simulator
diff --git a/lasercalc-git.install b/lasercalc-git.install
new file mode 100644
index 000000000000..2b00cbeff017
--- /dev/null
+++ b/lasercalc-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ [ -x /usr/bin/update-desktop-database ] && /usr/bin/update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/patch_lasercalc.patch b/patch_lasercalc.patch
new file mode 100644
index 000000000000..407b1ebd67c3
--- /dev/null
+++ b/patch_lasercalc.patch
@@ -0,0 +1,17 @@
+diff --git a/LaserCalc/src/Makefile.am b/LaserCalc/src/Makefile.am
+index cbe7359..98abe50 100644
+--- a/LaserCalc/src/Makefile.am
++++ b/LaserCalc/src/Makefile.am
+@@ -142,9 +142,9 @@ EXTRA_lasercalc_SOURCES= \
+ resources.rc
+
+ lasercalc_LDADD=\
+- /usr/local/lib/libsaf.la \
+- /usr/local/lib/libproperties.la \
+- /usr/local/lib/libplot.la
++ -lsaf \
++ -lproperties \
++ -lplot
+
+ if WINDOWS
+ lasercalc_LDADD+=resources.o
diff --git a/patch_plot.patch b/patch_plot.patch
new file mode 100644
index 000000000000..478416fd08d7
--- /dev/null
+++ b/patch_plot.patch
@@ -0,0 +1,29 @@
+diff --git a/plot/Makefile.am b/plot/Makefile.am
+index 9d18475..c9fb5af 100644
+--- a/plot/Makefile.am
++++ b/plot/Makefile.am
+@@ -1,2 +1,2 @@
+-ACLOCAL_AMFLAGS = -I m4 -I /usr/local/share/aclocal
++ACLOCAL_AMFLAGS = -I m4 -I /usr/share/aclocal
+ SUBDIRS=src include
+diff --git a/plot/configure.ac b/plot/configure.ac
+index 1392b6e..186d4fa 100644
+--- a/plot/configure.ac
++++ b/plot/configure.ac
+@@ -2,6 +2,7 @@ AC_PREREQ([2.68])
+ AC_INIT([plot],[0.6],[udo.eisenbarth@arcor.de],[],[http://lasercalc.sourceforge.net])
+ AM_INIT_AUTOMAKE([-Wall -Werror])
+ LT_PREREQ([2.4.2])
++AM_PROG_AR
+ LT_INIT([dlopen])
+ AC_CONFIG_SRCDIR([src/Vector3D.cpp])
+ AC_CONFIG_MACRO_DIR([m4])
+@@ -24,7 +25,7 @@ if test "$wxWin" != 1; then
+ wxWidgets version is $reqwx or above.
+ ])
+ fi
+-CPPFLAGS="-D__GXX_EXPERIMENTAL_CXX0X__ $WX_CPPFLAGS -I/usr/local/include"
++CPPFLAGS="$WX_CPPFLAGS $CPPFLAGS"
+ AC_ARG_ENABLE(debug,
+ [[ --enable-debug use debug configuration]],
+ [
diff --git a/patch_properties.patch b/patch_properties.patch
new file mode 100644
index 000000000000..9c42ae584d34
--- /dev/null
+++ b/patch_properties.patch
@@ -0,0 +1,24 @@
+diff --git a/properties/Makefile.am b/properties/Makefile.am
+index 584f1e6..5fdc019 100644
+--- a/properties/Makefile.am
++++ b/properties/Makefile.am
+@@ -1,2 +1,2 @@
+-ACLOCAL_AMFLAGS = -I m4 -I /usr/local/share/aclocal
+-SUBDIRS = include src demo
+\ No newline at end of file
++ACLOCAL_AMFLAGS = -I m4 -I /usr/share/aclocal
++SUBDIRS = include src
+\ No newline at end of file
+diff --git a/properties/configure.ac b/properties/configure.ac
+index 1202173..90351e7 100644
+--- a/properties/configure.ac
++++ b/properties/configure.ac
+@@ -26,7 +26,7 @@ if test "$wxWin" != 1; then
+ wxWidgets version is $reqwx or above.
+ ])
+ fi
+-CPPFLAGS="$CPPFLAGS -D__GXX_EXPERIMENTAL_CXX0X__ $WX_CPPFLAGS -I/usr/local/include"
++CPPFLAGS="$WX_CPPFLAGS $CPPFLAGS"
+ AC_ARG_ENABLE(debug,
+ [[ --enable-debug use debug configuration]],
+ [
diff --git a/patch_saf.patch b/patch_saf.patch
new file mode 100644
index 000000000000..0062375d25c3
--- /dev/null
+++ b/patch_saf.patch
@@ -0,0 +1,22 @@
+diff --git a/SAF/Makefile.am b/SAF/Makefile.am
+index cd3de0c..3e54216 100644
+--- a/SAF/Makefile.am
++++ b/SAF/Makefile.am
+@@ -1,2 +1,2 @@
+-ACLOCAL_AMFLAGS = -I m4 -I /usr/local/share/aclocal
+-SUBDIRS = include src demo
++ACLOCAL_AMFLAGS = -I m4 -I /usr/share/aclocal
++SUBDIRS = include src
+diff --git a/SAF/configure.ac b/SAF/configure.ac
+index 4b4260b..0d46efa 100644
+--- a/SAF/configure.ac
++++ b/SAF/configure.ac
+@@ -36,7 +36,7 @@ AC_ARG_ENABLE(debug,
+ [
+ CXXCONF="-O3 -DNDEBUG"
+ ])
+-CPPFLAGS="$CPPFLAGS -D__GXX_EXPERIMENTAL_CXX0X__ $WX_CPPFLAGS -I/usr/local/include"
++CPPFLAGS="$WX_CPPFLAGS $CPPFLAGS"
+ CXXFLAGS="-std=c++0x -Wall -Wextra -pedantic $CXXCONF $WX_CXXFLAGS_ONLY"
+ LIBS="$LIBS $WX_LIBS"
+ AC_CONFIG_FILES(Makefile