summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Picht2021-12-18 09:28:24 +0000
committerMichael Picht2021-12-18 09:28:24 +0000
commit0e311b279c5f31f8029b4a6af5ff87d25d531350 (patch)
treef81d5e9df80ee33cd1ca0bb20c2f98f4502c9f7c
parent3e10f53b08d977452dfcd6ebae425179a23a08fb (diff)
downloadaur-0e311b279c5f31f8029b4a6af5ff87d25d531350.tar.gz
release v3.4.4
Signed-off-by: Michael Picht <mipi@fsfe.org>
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD42
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89a8ec64b085..0c4ac53e35dc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = smsync-git
pkgdesc = smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux
- pkgver = 3.4.0.r1.gc34ff52
+ pkgver = 3.4.4
pkgrel = 1
url = https://gitlab.com/mipimipi/smsync/
arch = x86_64
- arch = i686
license = GPL3
- makedepends = dep
+ makedepends = bash
makedepends = git
- makedepends = go-pie
+ makedepends = go
+ makedepends = make
depends = ffmpeg
+ provides = smsync
source = git+https://gitlab.com/mipimipi/smsync.git
+ validpgpkeys = 11ECD6695134183B3E7AF1C2223AAA374A1D59CE
sha256sums = SKIP
pkgname = smsync-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7e255d01a06f..5ab339ddb86b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# SPDX-FileCopyrightText: 2018-2020 Michael Picht
-#
-# SPDX-License-Identifier: GPL-3.0-or-later
-
-# Maintainer: Michael Picht <michael dot picht at ussenterprise dot de>
+# Maintainer: Michael Picht <mipi@fsfe.org>
_pkgorg=gitlab.com/mipimipi
pkgname=smsync-git
_pkgname=smsync
-pkgver=3.4.0.r1.gc34ff52
+pkgver=3.4.4
pkgrel=1
pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux"
-arch=('x86_64' 'i686')
+arch=(x86_64)
url="https://$_pkgorg/$_pkgname/"
-license=('GPL3')
-depends=('ffmpeg')
+license=(GPL3)
+source=("git+https://$_pkgorg/$_pkgname.git")
+validpgpkeys=(11ECD6695134183B3E7AF1C2223AAA374A1D59CE) # Michael Picht <mipi@fsfe.org>
+sha256sums=('SKIP')
+depends=(ffmpeg)
makedepends=(
- dep
+ bash
git
- go-pie
+ go
+ make
)
-source=("git+https://$_pkgorg/$_pkgname.git")
-sha256sums=('SKIP')
+provides=(smsync)
pkgver() {
- cd "$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ ( set -o pipefail
+ git describe --tags --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {
@@ -36,13 +38,11 @@ prepare() {
}
build() {
- export GOPATH="$srcdir"/gopath
- cd gopath/src/$_pkgorg/$_pkgname
- make VERSION=$pkgver
+ cd "$srcdir/$_pkgname"
+ make
}
package() {
- export GOPATH="$srcdir"/gopath
- cd gopath/src/$_pkgorg/$_pkgname
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
}