summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 21:53:30 +0200
committeroli2015-06-12 21:53:30 +0200
commit0e36b54e2cd153d772441d2c52bf6d1756576aec (patch)
tree0a7d927d60a3e0a7907cbd61e4572a7efc11aac9
downloadaur-0e36b54e2cd153d772441d2c52bf6d1756576aec.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--fotbal.desktop7
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e557d81df07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fotbal
+ pkgdesc = a simple 2d soccer game
+ pkgver = 1
+ pkgrel = 4
+ url = http://hippo.nipax.cz/download.cz.php?id=41
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ depends = allegro
+ source = http://hippo.nipax.cz/src/fotbal-src.tar.gz
+ source = fotbal.desktop
+ md5sums = ed4146b05c3a074cd63c483bb685b1ed
+ md5sums = 3a8909900f3778dbed46a5008dd9eda9
+
+pkgname = fotbal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b460b50be28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: jose <jose1711 [at] gmail (dot) com>
+
+pkgname=fotbal
+pkgver=1
+pkgrel=4
+pkgdesc="a simple 2d soccer game"
+url=('http://hippo.nipax.cz/download.cz.php?id=41')
+arch=('i686' 'x86_64')
+license=("GPL-2")
+depends=('allegro')
+source=("http://hippo.nipax.cz/src/${pkgname}-src.tar.gz" "fotbal.desktop")
+md5sums=('ed4146b05c3a074cd63c483bb685b1ed'
+ '3a8909900f3778dbed46a5008dd9eda9')
+
+build() {
+cd $srcdir/${pkgname}-src
+# some patching needed here
+sed -i -e 's/<fstream.h>/<fstream>/' -e 's/ifstream/std::ifstream/' football.cxx
+make
+}
+
+package() {
+cd $srcdir/${pkgname}-src
+mkdir -p $pkgdir/usr/{share/fotbal,bin}
+install -D -m755 football $pkgdir/usr/share/fotbal/football
+install -D -m644 *.pcx *.txt fotbal.dat $pkgdir/usr/share/fotbal
+( echo "#!/bin/bash
+cd /usr/share/fotbal
+./football" ) > $pkgdir/usr/bin/fotbal
+chmod 755 $pkgdir/usr/bin/fotbal
+install -D -m644 $srcdir/fotbal.desktop $pkgdir/usr/share/applications/fotbal.desktop
+}
diff --git a/fotbal.desktop b/fotbal.desktop
new file mode 100644
index 000000000000..aa4062c2ed9d
--- /dev/null
+++ b/fotbal.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Fotbal
+GenericName=Sports Game
+Comment=Simple soccer game
+Exec=fotbal
+Categories=Game;SportsGame;