summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Pujol2022-02-24 23:05:46 +0000
committerAlexandre Pujol2022-02-24 23:05:46 +0000
commit0e3adc7433abefa843cae1372b96105ab36ec97a (patch)
treeb2fb5f35b2a77558481621be252a2784b99399c8
parentfa869c4ea92a4742362ff220e1d768b077b3099b (diff)
downloadaur-0e3adc7433abefa843cae1372b96105ab36ec97a.tar.gz
upgpkg: debops 3.0.1-2
Add new missing deps.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92e5c3ef6f7..8467c4ba9d38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
pkgbase = debops
pkgdesc = Your Debian-based data center in a box
pkgver = 3.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://debops.org/
arch = any
license = GPL3
makedepends = python-setuptools
- depends = python
depends = ansible
- depends = python-future
- depends = util-linux
depends = encfs
depends = gnupg
+ depends = python-distro
+ depends = python-dotenv
+ depends = python-future
+ depends = python-jinja
+ depends = python-pyxdg
+ depends = python-toml
+ depends = python-yaml
+ depends = python
+ depends = util-linux
optdepends = python-dnspython: required by Ansible "dig" module
optdepends = python-pyopenssl: required by "openssl_*" Ansible modules
optdepends = python-netaddr: required by Ansible "ipaddr" filter plugin
diff --git a/PKGBUILD b/PKGBUILD
index fbeb7ad811fa..0ad55e001921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,25 @@
pkgname=debops
pkgver=3.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Your Debian-based data center in a box"
arch=('any')
url="https://debops.org/"
license=('GPL3')
-depends=('python' 'ansible' 'python-future' 'util-linux' 'encfs' 'gnupg')
+depends=(
+ 'ansible'
+ 'encfs'
+ 'gnupg'
+ 'python-distro'
+ 'python-dotenv'
+ 'python-future'
+ 'python-jinja'
+ 'python-pyxdg'
+ 'python-toml'
+ 'python-yaml'
+ 'python'
+ 'util-linux'
+)
optdepends=(
'python-dnspython: required by Ansible "dig" module'
'python-pyopenssl: required by "openssl_*" Ansible modules'