summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2021-04-18 18:47:42 +0200
committerÓscar García Amor2021-04-18 18:47:42 +0200
commit0e85707c2df865549145ec929a36f90b09708ed3 (patch)
tree562b054b1c53059dce3df13ca38180d751f1460a
parent6b1124aa498bdda668aca217ed3c2fa9b2a56860 (diff)
downloadaur-0e85707c2df865549145ec929a36f90b09708ed3.tar.gz
upgpkg: timeline 1.8-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a5ed1beb9f3..ad812d6e24d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = timeline
pkgdesc = A plain-text based distributed social network build on top of git configuration manager
- pkgver = 1.7
+ pkgver = 1.8
pkgrel = 1
url = https://ajdiaz.me/timeline/
arch = any
- license = GPLv3
+ license = GPL3
+ makedepends = pandoc
depends = bash
depends = git
conflicts = timeline-git
- source = https://github.com/ajdiaz/timeline/archive/1.7.tar.gz
+ source = https://github.com/ajdiaz/timeline/archive/1.8.tar.gz
source = timeline.service
- sha256sums = 63ef34c4f5252ccc711a8efb96419feea8b1657afb2d9c7cf41604f927c4292b
+ sha256sums = e4a11c24d5934521952f21580af570fbf86d81c94529b952c808b9796b54f4b2
sha256sums = ef063a64b2e38988cf7b7395161351e537e50719f4d77fa3d180e25b911371fd
pkgname = timeline
diff --git a/PKGBUILD b/PKGBUILD
index 2c12131c9bcf..dee19df6b658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=timeline
-pkgver=1.7
+pkgver=1.8
pkgrel=1
pkgdesc="A plain-text based distributed social network build on top of git configuration manager"
arch=('any')
url="https://ajdiaz.me/timeline/"
-license=('GPLv3')
+license=('GPL3')
depends=('bash' 'git')
+makedepends=('pandoc')
conflicts=('timeline-git')
source=("https://github.com/ajdiaz/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.service")
-sha256sums=('63ef34c4f5252ccc711a8efb96419feea8b1657afb2d9c7cf41604f927c4292b'
+sha256sums=('e4a11c24d5934521952f21580af570fbf86d81c94529b952c808b9796b54f4b2'
'ef063a64b2e38988cf7b7395161351e537e50719f4d77fa3d180e25b911371fd')
prepare() {
@@ -22,6 +23,8 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
make clean && make
+ cd man
+ gzip -fk *.[0-9]
}
package() {
@@ -34,6 +37,13 @@ package() {
# binary
install -D -m755 "tl" "${pkgdir}/usr/bin/tl"
+ # man
+ for manpage in man/*.[0-9]; do
+ section=${manpage##*.}
+ install -Dm644 ${manpage}.gz \
+ "${pkgdir}"/usr/share/man/man${section}/${manpage##*/}.gz
+ done
+
# docs
install -D -m644 README "${pkgdir}/usr/share/doc/${_pkgname}/README"
}