summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-06 05:39:26 +1100
committerPumpkinCheshire2020-11-06 05:39:26 +1100
commit0e9c421cc38da89eaea66a3623e3722507669c2f (patch)
treebdf044cf75be81b44a7cb686c77ddd2f5862a608
downloadaur-0e9c421cc38da89eaea66a3623e3722507669c2f.tar.gz
first build
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdafd02181cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-mercantile
+ pkgdesc = Context geo-tiles in Python
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://github.com/mapbox/mercantile
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-click
+ optdepends = check-manifest: dev tools
+ optdepends = python-coveralls: test tools
+ optdepends = python-hypothesis: test tools
+ optdepends = python-pytest-cov: test tools
+ optdepends = python-pydocstyle: doc style control
+ source = https://files.pythonhosted.org/packages/source/m/mercantile/mercantile-1.1.6.tar.gz
+ source = https://github.com/mapbox/mercantile/blob/master/LICENSE.txt
+ sha256sums = 0dff4cbc2c92ceca0e0dfbb3dc74392a96d33cfa29afb1bdfcc80283d3ef4207
+ sha256sums = d89ff39f64a9287c61787591d9771b8d9fe100a393f31e906d377c4ecf694ac6
+
+pkgname = python-mercantile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31c90dfbee91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+pkgname='python-mercantile'
+_name=mercantile
+pkgver=1.1.6
+pkgrel=1
+pkgdesc='Context geo-tiles in Python'
+arch=('any')
+url='https://github.com/mapbox/mercantile'
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python-click')
+optdepends=('check-manifest: dev tools'
+ 'python-coveralls: test tools'
+ 'python-hypothesis: test tools'
+ 'python-pytest-cov: test tools'
+ 'python-pydocstyle: doc style control')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ 'https://github.com/mapbox/mercantile/blob/master/LICENSE.txt')
+sha256sums=('0dff4cbc2c92ceca0e0dfbb3dc74392a96d33cfa29afb1bdfcc80283d3ef4207'
+ 'd89ff39f64a9287c61787591d9771b8d9fe100a393f31e906d377c4ecf694ac6')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}