summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-04 10:20:20 +0200
committerxantares2015-07-04 10:20:20 +0200
commit0ea0952307737b91ccf219110dead42bdda6bcb6 (patch)
tree97a22bf1b95de2aa7bdea701f368a68816108778
parent5cf594fd5bc9cad2bbabca899a01fb1b6bbf3ccf (diff)
downloadaur-0ea0952307737b91ccf219110dead42bdda6bcb6.tar.gz
fix #56
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 945611dcd0df..3e61a02c2873 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,7 +15,7 @@ pkgbase = psp-newlib
source = ftp://sourceware.org/pub/newlib/newlib-1.20.0.tar.gz
source = https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-1.20.0-PSP.patch
md5sums = e5488f545c46287d360e68a801d470e8
- md5sums = SKIP
+ md5sums = 299d12b29bd492fe21bb27f72f1de548
pkgname = psp-newlib
diff --git a/PKGBUILD b/PKGBUILD
index e8ac7a41af0e..279f70cb7e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,16 @@ options=('!buildflags' '!strip' 'staticlibs')
source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz"
"https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch")
md5sums=('e5488f545c46287d360e68a801d470e8'
- 'SKIP')
+ '299d12b29bd492fe21bb27f72f1de548')
prepare ()
{
cd "$srcdir/newlib-$pkgver"
rm -rf newlib/libc/sys/psp/
patch -p1 -i "$srcdir"/newlib-$pkgver-PSP.patch
+
+ # https://github.com/pspdev/psptoolchain/pull/56
+ sed -i "s|time.o_link.o|time.o _link.o|g" newlib/libc/sys/psp/Makefile.in
}
build()