aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Ismailaj2020-04-05 16:24:50 +0200
committerDenis Ismailaj2020-04-05 16:26:57 +0200
commit0eab9893f4faf548eb5784a89944774bcef4456b (patch)
tree90e47d6e3bddf690d78ed357798a8cc090a6c386
parentae8e11da37b59dd22944039bbb2923edf480218d (diff)
downloadaur-0eab9893f4faf548eb5784a89944774bcef4456b.tar.gz
Update README
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md17
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 243f7987c558..b70967d72ff3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3-auto-arrange
pkgdesc = This is a simple Shell script that will automatically rearrange i3 workspaces
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/denis-ismailaj/i3-auto-arrange
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 82139c37888f..96fffb605b6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Denis Ismailaj <denis.ismailaj1@gmail.com>
pkgname=i3-auto-arrange
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="This is a simple Shell script that will automatically rearrange i3 workspaces"
arch=('any')
diff --git a/README.md b/README.md
index 271ffa3689a2..c730e348e155 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,17 @@
# i3-auto-arrange
-A Shell script that automatically rearranges i3 workspaces in order to get rid of gaps in ordering
+This tool is designed to help you when you have many workspaces open in `i3`, and when you close some of them you end up with gaps in the numbering. Instead of arranging them one by one, you can run `i3-auto-arrange` and it will automatically do it for you.
+
+### Installation
+You can find this script as a package on the AUR (Arch User Repository): https://aur.archlinux.org/packages/i3-auto-arrange
+
+Using a package helper such as `yay`, you could run `yay -S i3-auto-arrange`
+
+Or, to install from source instead:
+```
+$ git clone https://github.com/denis-ismailaj/i3-auto-arrange.git
+$ cd i3-auto-arrange
+$ makepkg
+```
+### Dependencies
+- `i3-wm` (obviously)
+- `jq` (needed to parse output from `i3-msg`)