summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAgustin Carrasco2018-10-03 01:54:02 -0300
committerAgustin Carrasco2018-10-03 01:54:02 -0300
commit0ec43f8397e69ecf4de6b4872f785846b5a639c4 (patch)
tree0eeb016daf2ce48d1c518e2cc7a35a8e238965c1
downloadaur-0ec43f8397e69ecf4de6b4872f785846b5a639c4.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58b6630ccbd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-ubuntu-mono
+ pkgdesc = Patched font UbuntuMono from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-inconsolata
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/UbuntuMono.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = 577219591b69ef05e539e19e716a01412a560633
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-ubuntu-mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc00cb9df7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Agustin Carrasco <asermax at gmail dot com>
+pkgname=nerd-fonts-ubuntu-mono
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font UbuntuMono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-inconsolata')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/UbuntuMono.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('577219591b69ef05e539e19e716a01412a560633'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}