summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramadejpapez2021-09-19 12:38:39 +0200
committeramadejpapez2021-09-19 12:38:39 +0200
commit0ece29619fd47c3c22171ebc44dc1fcca016f6d7 (patch)
treed25748f2d956babe702ca6462f6608e48b2c2ab1
parent9085cc0dcd448acb4e0167ed15d131fe30e32c2d (diff)
downloadaur-0ece29619fd47c3c22171ebc44dc1fcca016f6d7.tar.gz
Use pyproject.toml, added my email
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD31
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28ed6c1516e4..fdd5ff876b55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-name-that-hash
pkgdesc = The Modern Hash Identification System.
pkgver = 1.10.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/HashPals/Name-That-Hash
arch = any
license = GPL3
makedepends = python-setuptools
+ makedepends = python-dephell
depends = python
depends = python-click
depends = python-rich
diff --git a/PKGBUILD b/PKGBUILD
index 1ad6177e3bb9..8fb2f9e1c2bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: amadejpapez
-# Previous maintainer: Machina <machinax@protonmail.com>
+# Maintainer: amadejpapez <contact@amadejpapez.com>
-pkgname='python-name-that-hash'
-_pkgname='name-that-hash'
+pkgname=python-name-that-hash
+_pkgname=name-that-hash
pkgver=1.10.0
-pkgrel=2
+pkgrel=3
pkgdesc="The Modern Hash Identification System."
-arch=('any')
+arch=("any")
url="https://github.com/HashPals/Name-That-Hash"
-license=('GPL3')
-depends=('python' 'python-click' 'python-rich')
-makedepends=('python-setuptools')
+license=("GPL3")
+depends=("python" "python-click" "python-rich")
+makedepends=("python-setuptools" "python-dephell")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('aabe1a3e23f5f8ca1ef6522eb1adcd5c69b5fed3961371ed84a22fc86ee648a2')
+sha256sums=("aabe1a3e23f5f8ca1ef6522eb1adcd5c69b5fed3961371ed84a22fc86ee648a2")
-build()
-{
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build() {
cd "$_pkgname-$pkgver"
python setup.py build
}
-package()
-{
+package() {
cd "$_pkgname-$pkgver"
python setup.py install --prefix="/usr" --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}