summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoratomlong2021-11-09 10:58:21 +0800
committeratomlong2021-11-09 10:58:21 +0800
commit0ef6fce4e55c5dcfe15170fb871e472fdaa359b7 (patch)
tree028176a8f2f869cb04c3e88ecafa895403ee6ee5
downloadaur-0ef6fce4e55c5dcfe15170fb871e472fdaa359b7.tar.gz
Initial commit.
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD59
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56a523cc8d0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = python-aiohttp-git
+ pkgdesc = HTTP client/server for asyncio
+ pkgver = 4.0.0a1.r857.gac0398a4
+ pkgrel = 1
+ url = https://aiohttp.readthedocs.io
+ arch = x86_64
+ license = Apache
+ checkdepends = python-pytest
+ checkdepends = python-pytest-runner
+ checkdepends = python-pytest-mock
+ checkdepends = python-pytest-timeout
+ checkdepends = python-async_generator
+ checkdepends = python-brotli
+ checkdepends = python-pytest-xdist
+ checkdepends = python-pytest-forked
+ checkdepends = python-pytest-cov
+ checkdepends = python-trustme
+ checkdepends = python-freezegun
+ checkdepends = gunicorn
+ checkdepends = python-re-assert
+ makedepends = cython
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = python-chardet
+ depends = python-multidict
+ depends = python-async-timeout
+ depends = python-yarl
+ depends = python-attrs
+ optdepends = gunicorn: to deploy using Gunicorn
+ optdepends = python-aiodns: for fast DNS resolving
+ optdepends = python-cchardet: for faster encoding detection
+ optdepends = python-brotli: for Brotli transfer-encodings support
+ provides = python-aiohttp
+ conflicts = python-aiohttp
+ source = aiohttp::git+https://github.com/aio-libs/aiohttp
+ source = git+https://github.com/nodejs/http-parser
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = python-aiohttp-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea9d0cf7f3e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Philipp A. <flying-sheep@web.de>
+
+_pkgname=aiohttp
+pkgname=python-${_pkgname}-git
+pkgver=4.0.0a1.r857.gac0398a4
+pkgrel=1
+pkgdesc='HTTP client/server for asyncio'
+url='https://aiohttp.readthedocs.io'
+arch=('x86_64')
+license=('Apache')
+depends=('python' 'python-chardet' 'python-multidict' 'python-async-timeout'
+ 'python-yarl' 'python-attrs')
+makedepends=('cython' 'python-setuptools' 'git')
+checkdepends=('python-pytest' 'python-pytest-runner' 'python-pytest-mock'
+ 'python-pytest-timeout' 'python-async_generator' 'python-brotli'
+ 'python-pytest-xdist' 'python-pytest-forked' 'python-pytest-cov'
+ 'python-trustme' 'python-freezegun' 'gunicorn' 'python-re-assert')
+optdepends=('gunicorn: to deploy using Gunicorn'
+ 'python-aiodns: for fast DNS resolving'
+ 'python-cchardet: for faster encoding detection'
+ 'python-brotli: for Brotli transfer-encodings support')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(${_pkgname}::"git+https://github.com/aio-libs/aiohttp"
+ git+https://github.com/nodejs/http-parser)
+sha512sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ git submodule init
+ git config submodule."vendor/http-parser".url "${srcdir}/http-parser"
+ git submodule update --recursive
+ sed 's|.install-cython ||' -i Makefile
+}
+
+build() {
+ cd ${_pkgname}
+ make cythonize
+ python setup.py build
+}
+
+check() {
+ cd ${_pkgname}
+ python setup.py test
+}
+
+package() {
+ cd ${_pkgname}
+ python setup.py install --root="${pkgdir}" -O1 --skip-build
+}
+
+# vim: ts=2 sw=2 et: