summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-03-05 20:32:11 +0100
committerMarco Rubin2024-03-05 20:32:11 +0100
commit0f0be02a20ef4b58d7f9bb5528d7c10acfbfaf48 (patch)
treed649f58d10957a9aedd4d6aeb953123c05a39393
parent4c296a2ac53d7ba76860efba473b1deb502a5ccd (diff)
downloadaur-0f0be02a20ef4b58d7f9bb5528d7c10acfbfaf48.tar.gz
20240304
-rwxr-xr-x[-rw-r--r--].SRCINFO22
-rwxr-xr-x[-rw-r--r--]PKGBUILD27
2 files changed, 33 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 175cf1bab5fc..3242bba2f1e5 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,31 @@
pkgbase = hotspot
pkgdesc = The Linux perf GUI for performance analysis
- pkgver = 20240201
+ pkgver = 20240304
pkgrel = 1
url = https://github.com/KDAB/hotspot
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = cmake>=3.16.0
makedepends = desktop-file-utils
makedepends = extra-cmake-modules
makedepends = git
- depends = qt5-base>=5.15.0
- depends = libelf
depends = elfutils
- depends = threadweaver5
+ depends = kconfig5
+ depends = kconfigwidgets5
+ depends = kcoreaddons5
depends = kddockwidgets
depends = ki18n5
- depends = kconfig5
depends = kio5
- depends = kitemviews5
- depends = kcoreaddons5
depends = kitemmodels5
- depends = kconfigwidgets5
+ depends = kitemviews5
depends = kparts5
+ depends = libelf
depends = perf
- depends = solid5
+ depends = qt5-base>=5.15.0
depends = rustc-demangle>=0.1.18-2
- source = git+https://github.com/KDAB/hotspot#commit=95ecb77fbd8b0ab985c79d8c46659eee69ba95d5
+ depends = solid5
+ depends = threadweaver5
+ source = git+https://github.com/KDAB/hotspot#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f
b2sums = SKIP
pkgname = hotspot
diff --git a/PKGBUILD b/PKGBUILD
index 2d4f86819ac4..c36573c7c580 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,33 @@
# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
-# Contributor: Florian Lindner <florian.lindner@xgm.de>
+# Contributor: Florian Lindner <florian.lindner@xgm.de>
pkgname=hotspot
-pkgver=20240201
+pkgver=20240304
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('x86_64')
url="https://github.com/KDAB/hotspot"
-license=('GPL2')
-depends=('qt5-base>=5.15.0' 'libelf' 'elfutils' 'threadweaver5' 'kddockwidgets' 'ki18n5' 'kconfig5' 'kio5' 'kitemviews5' 'kcoreaddons5' 'kitemmodels5' 'kconfigwidgets5' 'kparts5' 'perf' 'solid5' 'rustc-demangle>=0.1.18-2')
+license=('GPL-2.0-only')
+depends=(
+ 'elfutils'
+ 'kconfig5'
+ 'kconfigwidgets5'
+ 'kcoreaddons5'
+ 'kddockwidgets'
+ 'ki18n5'
+ 'kio5'
+ 'kitemmodels5'
+ 'kitemviews5'
+ 'kparts5'
+ 'libelf'
+ 'perf'
+ 'qt5-base>=5.15.0'
+ 'rustc-demangle>=0.1.18-2'
+ 'solid5'
+ 'threadweaver5'
+)
makedepends=('cmake>=3.16.0' 'desktop-file-utils' 'extra-cmake-modules' 'git')
-source=("git+$url#commit=95ecb77fbd8b0ab985c79d8c46659eee69ba95d5")
+source=("git+$url#commit=6f9f958c4ff68b3c94ccca0fa3c2d86c46c9185f")
b2sums=('SKIP')
prepare() {