summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Meury2015-12-08 16:34:56 +0100
committerCedric Meury2015-12-08 17:46:37 +0100
commit0f1258022ccba96b5aaf8bf71c90c8d7a6254fd8 (patch)
treeb99a5d66d2ce13be88b4246c59a69638932a7aee
downloadaur-0f1258022ccba96b5aaf8bf71c90c8d7a6254fd8.tar.gz
initial commit; version 4.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--my-agile-pomodoro3
-rw-r--r--my-agile-pomodoro.desktop9
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09bc7f2a8c54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = my-agile-pomodoro
+ pkgdesc = myAgilePomodoro - Time management software that brings you the best of Agile practices and the Pomodoro Technique, written in Java
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/mypomodoro/
+ arch = any
+ license = GPL3
+ depends = java-runtime
+ source = my-agile-pomodoro
+ source = my-agile-pomodoro.desktop
+ source = http://downloads.sourceforge.net/project/mypomodoro/myAgilePomodoro%204.1.0/myAgilePomodoro-4.1.0.jar
+ source = https://a.fsdn.com/allura/p/mypomodoro/icon
+ md5sums = 72971e5f5c4d8e6b88a9ea5eb16dc220
+ md5sums = 88bf0240b89e66d20af837bca4cb96d4
+ md5sums = 39bddcb903eb7a5848cc1d1f124d471b
+ md5sums = a3a2b89f4d03c31f261f01ac1c8e3d3c
+
+pkgname = my-agile-pomodoro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afcac84e44ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Cedric Meury <cedric@meury.com>
+
+pkgname=my-agile-pomodoro
+pkgver=4.1.0
+pkgrel=1
+pkgdesc='myAgilePomodoro - Time management software that brings you the best of Agile practices and the Pomodoro Technique, written in Java'
+arch=('any')
+url="http://sourceforge.net/projects/mypomodoro/"
+license=('GPL3')
+depends=('java-runtime')
+source=('my-agile-pomodoro'
+ 'my-agile-pomodoro.desktop'
+ 'http://downloads.sourceforge.net/project/mypomodoro/myAgilePomodoro%20'$pkgver'/myAgilePomodoro-'$pkgver'.jar'
+ 'https://a.fsdn.com/allura/p/mypomodoro/icon')
+md5sums=('72971e5f5c4d8e6b88a9ea5eb16dc220'
+ '88bf0240b89e66d20af837bca4cb96d4'
+ '39bddcb903eb7a5848cc1d1f124d471b'
+ 'a3a2b89f4d03c31f261f01ac1c8e3d3c')
+
+package() {
+ install -Dm 644 $srcdir/icon $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm 644 $srcdir/myAgilePomodoro-$pkgver.jar $pkgdir/usr/share/java/$pkgname/$pkgname.jar
+ install -Dm 644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+}
+
diff --git a/my-agile-pomodoro b/my-agile-pomodoro
new file mode 100644
index 000000000000..7ae89d492a5d
--- /dev/null
+++ b/my-agile-pomodoro
@@ -0,0 +1,3 @@
+#!/bin/sh
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/my-agile-pomodoro/my-agile-pomodoro.jar' ~/.my-agile-pomodoro
+
diff --git a/my-agile-pomodoro.desktop b/my-agile-pomodoro.desktop
new file mode 100644
index 000000000000..5aff926f9bde
--- /dev/null
+++ b/my-agile-pomodoro.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=myAgilePomodoro
+Comment=Time management software that brings you the best of Agile practices and the Pomodoro Technique, written in Java
+Exec=my-agile-pomodoro
+Icon=my-agile-pomodoro
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=Office;Java;TrayIcon;