summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2017-05-30 01:43:20 +0200
committerJohannes Dewender2017-05-30 01:43:20 +0200
commit0f3bea0d933e925f7cb57bbc27ee1fa35a2c00c4 (patch)
tree3b47d5a116fe3e3737e0269ccaaab221d434747b
parent3746ee99a6a3f106a082af6991de94d5443cbdd6 (diff)
downloadaur-0f3bea0d933e925f7cb57bbc27ee1fa35a2c00c4.tar.gz
fix binary symlinks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f9d0f9e501a..37ff939acaec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun May 21 17:32:53 UTC 2017
+# Mon May 29 23:43:09 UTC 2017
pkgbase = elasticdump2
pkgdesc = Import and export tools for Elasticsearch < 5
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.npmjs.com/package/elasticdump
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 57e8886e18ac..7fd693e0494d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=elasticdump2
_pkgname=elasticdump
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Import and export tools for Elasticsearch < 5"
arch=(any)
url="https://www.npmjs.com/package/elasticdump"
@@ -20,6 +20,9 @@ package() {
rm -r "$pkgdir/usr/etc"
mv "$pkgdir/usr/lib/node_modules/$_pkgname" "$pkgdir/usr/lib/node_modules/$pkgname"
- mv "$pkgdir/usr/bin/$_pkgname" "$pkgdir/usr/bin/$pkgname"
- mv "$pkgdir/usr/bin/multi$_pkgname" "$pkgdir/usr/bin/multi$pkgname"
+ rm "$pkgdir/usr/bin/$_pkgname"
+ rm "$pkgdir/usr/bin/multi$_pkgname"
+ cd "$pkgdir/usr/bin"
+ ln -s "../lib/node_modules/$pkgname/bin/$_pkgname" $pkgname
+ ln -s "../lib/node_modules/$pkgname/bin/multi$_pkgname" multi$pkgname
}