summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-02-05 19:08:53 +1100
committerMatthew Gamble2022-02-05 19:08:53 +1100
commit0f6b0aea620571bd8f898faea037d295eec3d2ce (patch)
treef66c126ab48b2464570935b06a96cc22b0884823
parent6c7685710a6d2fe0afca7ba979668c7eb20d44a1 (diff)
downloadaur-0f6b0aea620571bd8f898faea037d295eec3d2ce.tar.gz
Cleanup, make package build in a clean chroot, bump pkgrel for py3.10
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be1039a5109d..bc8209e3a067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Jose Riha <jose1711 gmail com>
pkgname=python-birdseye
-_module=birdseye
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="Graphical Python debugger which lets you view the values of all evaluated expressions"
url="http://github.com/alexmojaki/birdseye"
depends=(python-littleutils python-flask-humanize python-humanize python-flask-humanize python-cheap_repr python-outdated python-sqlalchemy python-cached-property python-future python-asttokens)
-makedepends=('python-setuptools')
+makedepends=('python-setuptools-scm')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/b/birdseye/birdseye-${pkgver}.tar.gz")
sha256sums=('8a43008afe6c7d54c59a117fe6c818bc8cdd895bb8aa0b0949514073cbe809c0')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "birdseye-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "birdseye-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-birdseye/LICENSE.txt"
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/python-birdseye/README.rst
}