summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIcaro Perseo2016-10-21 20:49:49 -0500
committerIcaro Perseo2016-10-21 20:49:49 -0500
commit0f7d6b0b58887fc9f2b8f9cf842ed404bbf3db06 (patch)
tree9360ede03f5860ac13ba13ea7a817186eb8761d5
parent95df8273d3cd248ffec537c59b3fd510722310e9 (diff)
downloadaur-0f7d6b0b58887fc9f2b8f9cf842ed404bbf3db06.tar.gz
New maintainer. Package updated.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--papirus-plasma-theme.install6
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4181b1900cb7..a619e52c6741 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Aug 7 18:36:30 UTC 2016
pkgbase = papirus-plasma-theme
pkgdesc = Papirus plasma theme for KDE
- pkgver = 20160807
+ pkgver = 20160811
pkgrel = 1
url = https://github.com/PapirusDevelopmentTeam/papirus-plasma-theme
install = papirus-plasma-theme.install
@@ -13,7 +11,7 @@ pkgbase = papirus-plasma-theme
depends = plasma-desktop
conflicts = papirus-plasma-theme-git
options = !strip
- source = papirus-plasma-theme::git+https://github.com/PapirusDevelopmentTeam/papirus-plasma-theme.git#commit=5196c8c
+ source = papirus-plasma-theme::git+https://github.com/PapirusDevelopmentTeam/papirus-plasma-theme.git#commit=ece39e5
sha256sums = SKIP
pkgname = papirus-plasma-theme
diff --git a/PKGBUILD b/PKGBUILD
index 8249436ad18e..7584efad04e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: FadeMind <fademind@gmail.com>
+# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
+# Contributor: FadeMind <fademind@gmail.com>
pkgname=papirus-plasma-theme
-_commit=5196c8c # 7 digits
-pkgver=20160807
+_commit=ece39e5 # 7 digits
+pkgver=20160811
pkgrel=1
pkgdesc="Papirus plasma theme for KDE"
url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
@@ -17,10 +18,12 @@ source=("${pkgname}::git+${url}.git#commit=${_commit}")
sha256sums=('SKIP')
pkgver() {
- cd ${pkgname}
- git log -1 --format="%cd" --date=short | tr -d '-'
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
}
package() {
- make -C "${pkgname}" install DESTDIR="$pkgdir"
+ make -C "${pkgname}" install DESTDIR="$pkgdir"
}
+
+# vim:set ts=2 sw=2 cc=80 et:
diff --git a/papirus-plasma-theme.install b/papirus-plasma-theme.install
index 83150ca06ef6..647b630bc5d7 100644
--- a/papirus-plasma-theme.install
+++ b/papirus-plasma-theme.install
@@ -1,13 +1,13 @@
plasma-cache-refresh() {
_l="/etc/login.defs"
_p="/etc/passwd"
-
+
## get mini UID limit ##
l=$(grep "^UID_MIN" $_l)
-
+
## get max UID limit ##
l1=$(grep "^UID_MAX" $_l)
-
+
## use awk to print if UID >= $MIN and UID <= $MAX and shell is not /sbin/nologin ##
users=$(awk -F':' -v "min=${l##UID_MIN}" -v "max=${l1##UID_MAX}" '{ if ( $3 >= min && $3 <= max && $7 != "/sbin/nologin" ) print $0 }' "$_p" | cut -d: -f1)
for u in $users; do