summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Walenciak2020-05-19 20:52:08 +0200
committerMichał Walenciak2020-05-19 20:52:08 +0200
commit0f842a2fc5d845c93b5fa7958cef2298e9138599 (patch)
tree4748f3f7aa2a939b9e36facc14202e09f4f04109
parent7cab778dac4c8d1fdb686b2fb342a6984160c60b (diff)
downloadaur-0f842a2fc5d845c93b5fa7958cef2298e9138599.tar.gz
bumping version to 0.8.2
- adding SDL dependencies - removing useless patch
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Fixed-AppImage-data-path.patch38
-rw-r--r--PKGBUILD17
3 files changed, 20 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 779235dca398..4ea9356d1996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = openblok
pkgdesc = A customizable, cross platform, open-source falling block game, packed with a bunch of features.
- pkgver = 0.7.0
- pkgrel = 3
+ pkgver = 0.8.2
+ pkgrel = 1
url = https://github.com/mmatyas/openblok
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
- source = https://codeload.github.com/mmatyas/openblok/tar.gz/v0.7.0
- source = 0001-Fixed-AppImage-data-path.patch
- md5sums = 0c82fadc6573e4fa0fe84171d169d978
- md5sums = 47cb3991c7997149f9229230969342ee
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ source = https://codeload.github.com/mmatyas/openblok/tar.gz/v0.8.2
+ source = libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#branch=cmake_modernization
+ md5sums = 6dd426a1dec30c74036ae09113505659
+ md5sums = SKIP
pkgname = openblok
diff --git a/0001-Fixed-AppImage-data-path.patch b/0001-Fixed-AppImage-data-path.patch
deleted file mode 100644
index 2a8e76706959..000000000000
--- a/0001-Fixed-AppImage-data-path.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 8760fadf1a29bb078952b6c334dcb74bb5d066a1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?M=C3=A1ty=C3=A1s=20Mustoha?= <matyas.mustoha@gmail.com>
-Date: Mon, 27 Feb 2017 21:11:13 +0100
-Subject: [PATCH] Fixed AppImage data path
-
----
- src/CMakeLists.txt | 2 --
- src/system/CMakeLists.txt | 1 +
- 2 files changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index f07833e..5823868 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -5,8 +5,6 @@ include_directories(openblok PRIVATE "${CMAKE_CURRENT_BINARY_DIR}/generated")
-
- add_executable(openblok main.cpp version.h)
-
--target_compile_definitions(openblok PRIVATE OPENBLOK_DATADIR="${DATADIR}")
--
- add_subdirectory(system)
- add_subdirectory(game)
- target_link_libraries(openblok module_game)
-diff --git a/src/system/CMakeLists.txt b/src/system/CMakeLists.txt
-index 32274d7..9cc655e 100644
---- a/src/system/CMakeLists.txt
-+++ b/src/system/CMakeLists.txt
-@@ -50,6 +50,7 @@ add_library(module_system ${MOD_SYSTEM_SRC} ${MOD_SYSTEM_H})
-
- # use SDL2
- target_include_directories(module_system PRIVATE ${SDL2PP_INCLUDE_DIRS})
-+target_compile_definitions(module_system PRIVATE OPENBLOK_DATADIR="${DATADIR}")
- target_link_libraries(module_system ${SDL2PP_LIBRARIES})
-
- option(ENABLE_JPG "Enable JPG image support" ON)
---
-2.21.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 45cd13f38882..9a78acd96f14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=openblok
-pkgver=0.7.0
-pkgrel=3
+pkgver=0.8.2
+pkgrel=1
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
license=('GPL3')
groups=()
-depends=()
+depends=('sdl2'
+ 'sdl2_image'
+ 'sdl2_mixer'
+ 'sdl2_ttf')
makedepends=('cmake')
optdepends=()
provides=()
@@ -17,15 +20,15 @@ backup=()
options=()
install=
changelog=
-source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver 0001-Fixed-AppImage-data-path.patch)
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#branch=cmake_modernization)
noextract=()
-md5sums=('0c82fadc6573e4fa0fe84171d169d978'
- '47cb3991c7997149f9229230969342ee')
+md5sums=('6dd426a1dec30c74036ae09113505659'
+ 'SKIP')
build()
{
+ mv ./libSDL2pp/* $pkgname-$pkgver/thirdparty/libSDL2pp
cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/0001-Fixed-AppImage-data-path.patch"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin