summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kobel2016-02-12 09:05:51 +0100
committerAlexander Kobel2016-02-12 09:05:51 +0100
commit0f9e4b5042d4c131ee56a9ff8e64c2cd35a231e1 (patch)
tree72ec6dd1415d5c5b504daf4abe4de3821d390f42
downloadaur-0f9e4b5042d4c131ee56a9ff8e64c2cd35a231e1.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..386822aeca07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 5.0.0
+# Fri Feb 12 08:05:32 UTC 2016
+pkgbase = bertini
+ pkgdesc = Homotopy continuation solver for systems of polynomial equations
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://bertini.nd.edu/
+ arch = i686
+ arch = x86_64
+ license = custom: Bertini license
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = flex
+ makedepends = bison
+ depends = boost
+ depends = gmp
+ depends = mpfr
+ optdepends = openmpi: multithreading support
+ source = http://bertini.nd.edu/BertiniSource_v1.5.tar.gz
+ sha256sums = a9a68a96e180fe6a93ba1bc1d61f522784c9a053b049b2cbd98008b5b6deec3c
+
+pkgname = bertini
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffad8fe471fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
+
+pkgname=bertini
+pkgver=1.5
+pkgrel=1
+pkgdesc="Homotopy continuation solver for systems of polynomial equations"
+url="http://bertini.nd.edu/"
+arch=('i686' 'x86_64')
+license=('custom: Bertini license')
+depends=('boost' 'gmp' 'mpfr')
+optdepends=('openmpi: multithreading support')
+makedepends=('automake' 'autoconf' 'flex' 'bison')
+source=("http://bertini.nd.edu/BertiniSource_v${pkgver}.tar.gz")
+sha256sums=('a9a68a96e180fe6a93ba1bc1d61f522784c9a053b049b2cbd98008b5b6deec3c')
+
+prepare () {
+ cd ${srcdir}/BertiniSource_v${pkgver}
+ rm aclocal.m4 Makefile.in
+ aclocal
+ automake --add-missing
+ autoconf
+}
+
+build () {
+ cd ${srcdir}/BertiniSource_v${pkgver}
+ ./configure --prefix=/usr --includedir=/usr/include/bertini
+ make
+}
+
+package() {
+ cd ${srcdir}/BertiniSource_v${pkgver}
+ install -D -m644 Bertini_License "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 BertiniUsersManual.pdf "${pkgdir}/usr/share/doc/${pkgname}/BertiniUsersManual.pdf"
+ make DESTDIR="${pkgdir}" install
+}