summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-07-06 17:44:53 -0400
committerJames An2016-07-06 17:44:53 -0400
commit0feaa7c6b8bf06639baba64ed7d625d511f00ce7 (patch)
tree2c1141ef42063af4240a9fd65ad86c90c8220088
downloadaur-0feaa7c6b8bf06639baba64ed7d625d511f00ce7.tar.gz
Initial commit with working spec.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD46
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee58b72b30cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = php-datastructures-git
+ pkgdesc = PHP extensions for classes supporting common datastructures
+ pkgver = r11.c4d68d6
+ pkgrel = 1
+ url = https://github.com/eosforphp/php-datastructures
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = php
+ depends = cairo
+ provides = php-datastructures=r11.c4d68d6
+ conflicts = php-datastructures
+ source = php-datastructures::git+https://github.com/eosforphp/datastructures.git
+ md5sums = SKIP
+
+pkgname = php-datastructures-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..532d5ed1f20a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=php-datastructures-git
+_pkgname=${pkgname%-git}
+__pkgname=${_pkgname#php-}
+pkgver=r11.c4d68d6
+pkgrel=1
+pkgdesc='PHP extensions for classes supporting common datastructures'
+arch=('any')
+url="https://github.com/eosforphp/$_pkgname"
+license=('GPL')
+depends=('php' 'cairo')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname"::"git+https://github.com/eosforphp/$__pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$_pkgname"
+
+ NO_INTERACTION=1 make -k test
+}
+
+package() {
+ cd "$_pkgname"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}