aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2021-02-11 12:37:18 +0530
committerAmish2021-02-11 12:37:18 +0530
commit0ff9b2c5467dbfcd86263291114404cfc9a13c78 (patch)
treefe990bc99d2021896fda8dba76e54629ecbb1fc5
parent9e5ecbb9e54d58bc4b7dd43c6a97ec749c3e6636 (diff)
downloadaur-0ff9b2c5467dbfcd86263291114404cfc9a13c78.tar.gz
Rebuild with latest DB-IP database
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--mmcsv_geoip_build11
-rw-r--r--xt_geoip_build2
4 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccefbc93e478..1f706b6a80ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = xtables-geoip-db
pkgdesc = GeoIP Database for xtables
pkgver = 2.1
- pkgrel = 6
+ pkgrel = 7
url = https://db-ip.com/db/download/ip-to-country-lite
arch = any
license = BSD
license = GPL
makedepends = perl-text-csv-xs
makedepends = perl-net-cidr-lite
- source = dbip-country-lite-2021-01.csv.gz::https://download.db-ip.com/free/dbip-country-lite-2021-01.csv.gz
+ source = dbip-country-lite-2021-02.csv.gz::https://download.db-ip.com/free/dbip-country-lite-2021-02.csv.gz
source = README
source = xt_geoip_build
source = mmcsv_geoip_build
sha256sums = SKIP
sha256sums = bd1dbbacdde0c6b63b15c00a9b3cecada7c95bbd72cd2f7a336106fce53cddbd
- sha256sums = d47c67f8126915ef4f326befa3b3b50903e335efdc52967a401e17749b7b92bd
- sha256sums = beebf34ac2138e8916eb31450b50d693b174fe2f54626d8a858521b7391cbefc
+ sha256sums = ff867e1e2769b61ba9dcc825b73de37a46fe446bb4e3eb528dd7f15e960ce76b
+ sha256sums = 2ff950f3ed0e93722bf0477a4b0bd3fdd79d94b5631f073e80bc76f10d596cc3
pkgname = xtables-geoip-db
diff --git a/PKGBUILD b/PKGBUILD
index ef0382300509..f416ed3c2b8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Amish <contact at via dot aur>
pkgname=xtables-geoip-db
pkgver=2.1
-pkgrel=6
+pkgrel=7
pkgdesc="GeoIP Database for xtables"
arch=('any')
license=('BSD' 'GPL')
@@ -30,8 +30,8 @@ source+=('README'
'mmcsv_geoip_build')
sha256sums=('SKIP'
'bd1dbbacdde0c6b63b15c00a9b3cecada7c95bbd72cd2f7a336106fce53cddbd'
- 'd47c67f8126915ef4f326befa3b3b50903e335efdc52967a401e17749b7b92bd'
- 'beebf34ac2138e8916eb31450b50d693b174fe2f54626d8a858521b7391cbefc')
+ 'ff867e1e2769b61ba9dcc825b73de37a46fe446bb4e3eb528dd7f15e960ce76b'
+ '2ff950f3ed0e93722bf0477a4b0bd3fdd79d94b5631f073e80bc76f10d596cc3')
package() {
echo Using ${_dbsource} GeoIP database
diff --git a/mmcsv_geoip_build b/mmcsv_geoip_build
index 2dd9cbe13faa..ed7b38c85ce6 100644
--- a/mmcsv_geoip_build
+++ b/mmcsv_geoip_build
@@ -1,5 +1,5 @@
#!/usr/bin/perl
-# Source: https://sourceforge.net/p/xtables-addons/xtables-addons/ci/v3.7/tree/geoip/xt_geoip_build?format=raw
+# Source: https://inai.de/files/xtables-addons/xtables-addons-3.15.tar.xz
#
# Converter for MaxMind (GeoLite2) CSV database to binary, for xt_geoip
# Copyright Jan Engelhardt, 2008-2011
@@ -18,12 +18,15 @@ my $csv = Text::CSV_XS->new({
eol => $/,
}); # or Text::CSV
my $source_dir = ".";
+my $quiet = 0;
my $target_dir = ".";
&Getopt::Long::Configure(qw(bundling));
&GetOptions(
"D=s" => \$target_dir,
"S=s" => \$source_dir,
+ "q" => \$quiet,
+ "s" => sub { $target_dir = "/usr/share/xt_geoip"; },
);
if (!-d $source_dir) {
@@ -200,12 +203,12 @@ sub collect
$cidr = $row->[net];
$country{$cc}->{pool_v6}->add($cidr);
- if ($. % 4096 == 0) {
+ if (!$quiet && $. % 4096 == 0) {
print STDERR "\r\e[2K$. entries";
}
}
- print STDERR "\r\e[2K$. entries total\n";
+ print STDERR "\r\e[2K$. entries total\n" unless ($quiet);
close($fh);
@@ -246,7 +249,7 @@ sub writeCountry
printf "%5u IPv%s ranges for %s %s\n",
scalar(@ranges),
($family == AF_INET ? '4' : '6'),
- $iso_code, $name;
+ $iso_code, $name unless ($quiet);
my $file = "$target_dir/".uc($iso_code).".iv".($family == AF_INET ? '4' : '6');
if (!open($fh, '>', $file)) {
diff --git a/xt_geoip_build b/xt_geoip_build
index 7fd9eeea8ac4..3aab2b3b5dbc 100644
--- a/xt_geoip_build
+++ b/xt_geoip_build
@@ -1,5 +1,5 @@
#!/usr/bin/perl
-# Source: https://inai.de/files/xtables-addons/xtables-addons-3.10.tar.xz
+# Source: https://inai.de/files/xtables-addons/xtables-addons-3.15.tar.xz
#
# Converter for DBIP (Country Lite) CSV database to binary, for xt_geoip
# Copyright Jan Engelhardt, 2008-2011