summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrougnouf2020-07-10 23:31:50 +0200
committertrougnouf2020-07-10 23:31:50 +0200
commit1032be19809e94f0e6a67016e26413b7d7737821 (patch)
tree603bf5a0b4743d19c2b5e66e9308824dd69dd71a
downloadaur-1032be19809e94f0e6a67016e26413b7d7737821.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f56b25077047
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-scikit-video
+ pkgdesc = Video processing built on top of scipy, numpy, and ffmpeg/libav
+ pkgver = 1.1.11
+ pkgrel = 1
+ url = http://www.scikit-video.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = custom
+ depends = ffmpeg
+ depends = python-scikit-learn
+ depends = python-pillow
+ optdepends = mediainfo
+ source = https://github.com/scikit-video/scikit-video/archive/1.1.11.tar.gz
+ sha256sums = 0d28d9c08d43be56bd723c8387e90e599a5ce4b75c389717d190ccde0ef5d56f
+
+pkgname = python-scikit-video
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..315ded98b3c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name='scikit-video'
+pkgname="python-${_name}"
+pkgver=1.1.11
+pkgrel=1
+pkgdesc="Video processing built on top of scipy, numpy, and ffmpeg/libav"
+arch=('i686' 'x86_64')
+url="http://www.${_name}.org/"
+license=('BSD' 'custom')
+depends=('ffmpeg' 'python-scikit-learn' 'python-pillow')
+optdepends=('mediainfo')
+source=(https://github.com/${_name}/${_name}/archive/${pkgver}.tar.gz)
+sha256sums=('0d28d9c08d43be56bd723c8387e90e599a5ce4b75c389717d190ccde0ef5d56f')
+
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_name}-${pkgver}
+ install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --skip-build
+}