summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortercean2023-06-23 21:58:48 +0200
committertercean2023-06-23 21:58:48 +0200
commit108a3bbb726ef168fac9d06d5ed5ee78104da300 (patch)
tree38cf19db8e97b64903c726b1e896112e9adb3a38
parentbc9a9e62f470e94378b131309776fb90776210cd (diff)
downloadaur-108a3bbb726ef168fac9d06d5ed5ee78104da300.tar.gz
1.38.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--deltachat-desktop.sh2
-rw-r--r--static_build_info.patch2
4 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 025d75af81aa..d09d81d3722c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deltachat-desktop
pkgdesc = A privacy oriented chat application built on e-mail
- pkgver = 1.38.0
+ pkgver = 1.38.1
pkgrel = 1
url = https://github.com/deltachat/deltachat-desktop
arch = any
@@ -10,15 +10,15 @@ pkgbase = deltachat-desktop
makedepends = rustup
makedepends = python
makedepends = unzip
- depends = electron19
+ depends = electron22
conflicts = deltachat-desktop-git
- source = deltachat-desktop-1.38.0.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.38.0.tar.gz
+ source = deltachat-desktop-1.38.1.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.38.1.tar.gz
source = deltachat-desktop.desktop
source = deltachat-desktop.sh
source = static_build_info.patch
- sha256sums = 8c61aa6498b26c5052ebb0057cb76f3e5e05831930d4095276676dfe9475b220
+ sha256sums = d0532ae00827cd93e92b605b7ccac0e727dfefd42316447764bf2a384d36ec2a
sha256sums = 39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1
- sha256sums = 9b581cb127a74a7d6bcf67a1f0637dbcd00dca531db890e7a8be99919aaaa04d
- sha256sums = 8953f96b2b319c3f5ff0ec74d5b0a47f0d4c13c42e2a3aebcabfd91ee7ca8763
+ sha256sums = b857308f06369e49422bf9266694b576936034940e83b4d6d92174af3c0706c4
+ sha256sums = 6198acf448bec7a195a0af458aeb721a0e181c242c54e3f7341fcbdf0e11434a
pkgname = deltachat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 8e91ff3809d4..1ebbe8a1227b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: tercean <cg@zknt.org>
pkgname=deltachat-desktop
-pkgver=1.38.0
+pkgver=1.38.1
pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
-depends=('electron19')
+depends=('electron22')
makedepends=('npm' 'nodejs>=16' 'rustup' 'python' 'unzip')
conflicts=("deltachat-desktop-git")
source=(
@@ -15,10 +15,10 @@ source=(
"deltachat-desktop.sh"
"static_build_info.patch"
)
-sha256sums=('8c61aa6498b26c5052ebb0057cb76f3e5e05831930d4095276676dfe9475b220'
+sha256sums=('d0532ae00827cd93e92b605b7ccac0e727dfefd42316447764bf2a384d36ec2a'
'39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1'
- '9b581cb127a74a7d6bcf67a1f0637dbcd00dca531db890e7a8be99919aaaa04d'
- '8953f96b2b319c3f5ff0ec74d5b0a47f0d4c13c42e2a3aebcabfd91ee7ca8763')
+ 'b857308f06369e49422bf9266694b576936034940e83b4d6d92174af3c0706c4'
+ '6198acf448bec7a195a0af458aeb721a0e181c242c54e3f7341fcbdf0e11434a')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
index ec9ae1917090..d156ce61b3db 100644
--- a/deltachat-desktop.sh
+++ b/deltachat-desktop.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-cd /opt/DeltaChat/electron_app && electron19 . "$@"
+cd /opt/DeltaChat/electron_app && electron22 . "$@"
diff --git a/static_build_info.patch b/static_build_info.patch
index 48f4e582b1b0..f534372809ad 100644
--- a/static_build_info.patch
+++ b/static_build_info.patch
@@ -39,7 +39,7 @@ diff --unified --recursive --text orig/bin/build-shared-version-info.js patched/
- const git_ref =
- git_describe + (git_branch === 'master' ? '' : '-' + git_branch)
- return git_ref
-+ return "tags/v1.38.0"
++ return "tags/v1.38.1"
}
async function gatherBuildInfo() {