summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvitalyr2022-03-01 00:48:40 +0800
committervitalyr2022-03-01 00:48:40 +0800
commit108f15542f231ff7deb4ddf29ed29301b829d47c (patch)
treeb1ef0cc4bf8b6f1e768eefb330ff99b4dc69c075
parent7ff8c59ad28a37ea83e4f8f9573a8c578381b131 (diff)
downloadaur-108f15542f231ff7deb4ddf29ed29301b829d47c.tar.gz
Revert last commit to depends `libgccjit` again, since the `gcc` package is
split into `gcc` and `libgccjit`
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e259bcc6da1b..71d9f72107d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = emacs-native-comp-git-enhanced
depends = libxml2
depends = jansson
depends = harfbuzz
+ depends = libgccjit
depends = gtk3
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index c895690b4e07..141d0b32c817 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ MOLD="YES" # Use the mold linker.
# Notice that it will always be used.
JIT="YES" # Enable native just-in-time compilation. Use libgccjit,
- # which is already included in Arch's gcc package.
+ # which is in testing repo for now.
#
# This compiles only performance critical elisp files.
#
@@ -166,6 +166,14 @@ if [[ $CLANG == "YES" ]]; then
fi
fi
+if [[ $JIT == "YES" ]]; then
+ if [[ $CLI == "YES" ]]; then
+ depends_nox+=( 'libgccjit' );
+ else
+ depends+=( 'libgccjit' );
+ fi
+fi
+
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then