summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Brand2017-04-16 13:30:54 +0200
committerStefan Brand2017-04-16 13:30:54 +0200
commit10ac736b4af96126dcabe6d84cdce67aa6d35911 (patch)
tree02d95fb1df7e38c1afcd42aae6d091a18e6404fb
downloadaur-10ac736b4af96126dcabe6d84cdce67aa6d35911.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--001_fix_sysmacros_include.patch10
-rw-r--r--002_disable_postinstall.patch13
-rw-r--r--PKGBUILD44
-rw-r--r--thunderboltd-git.install6
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..886207e33e3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = thunderboltd-git
+ pkgdesc = Thunderbolt Daemon from the Intel Thunderbolt Software Userspace
+ pkgver = r13.1797ab5
+ pkgrel = 1
+ url = https://github.com/01org/thunderbolt-software-user-space
+ install = thunderboltd-git.install
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ depends = dbus-c++
+ depends = libnl
+ depends = thunderbolt-icm-dkms-git
+ provides = thunderboltd
+ conflicts = thunderboltd
+ source = thunderboltd::git+https://github.com/01org/thunderbolt-software-user-space.git#branch=fwupdate
+ source = 001_fix_sysmacros_include.patch
+ source = 002_disable_postinstall.patch
+ md5sums = SKIP
+ md5sums = 713ee1db7eea31db2cd5093c615225a3
+ md5sums = eb52425947438ed6f7f334bfe48f5066
+
+pkgname = thunderboltd-git
+
diff --git a/001_fix_sysmacros_include.patch b/001_fix_sysmacros_include.patch
new file mode 100644
index 000000000000..5ca67c177db0
--- /dev/null
+++ b/001_fix_sysmacros_include.patch
@@ -0,0 +1,10 @@
+--- ThunderboltService/Shared/include/Utils.h.orig 2017-04-16 12:58:14.030344417 +0200
++++ ThunderboltService/Shared/include/Utils.h 2017-04-16 12:58:29.493758083 +0200
+@@ -32,6 +32,7 @@
+ #define UTILS_H_
+ #include <memory>
+ #include <sstream>
++#include <sys/sysmacros.h>
+ #include "defines.h"
+ #include "MessagesWrapper.h"
+ #include "boost/crc.hpp"
diff --git a/002_disable_postinstall.patch b/002_disable_postinstall.patch
new file mode 100644
index 000000000000..81e5a3c1601e
--- /dev/null
+++ b/002_disable_postinstall.patch
@@ -0,0 +1,13 @@
+--- cmake_install.cmake.orig 2017-04-16 13:13:40.562121665 +0200
++++ cmake_install.cmake 2017-04-16 13:14:02.932269460 +0200
+@@ -104,10 +104,6 @@
+ endif()
+ endif()
+
+-if("${CMAKE_INSTALL_COMPONENT}" STREQUAL "script" OR NOT CMAKE_INSTALL_COMPONENT)
+- include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/ThunderboltService/Linux/post_install_script.cmake")
+-endif()
+-
+ if(NOT CMAKE_INSTALL_LOCAL_ONLY)
+ # Include the install script for each subdirectory.
+ include("/home/seiichiro/Misc/AUR/thunderboltd-git/src/thunderboltd/build/gmock/cmake_install.cmake")
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3442845b1413
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Stefan Brand <package@seiichiro0185.org>
+pkgname=thunderboltd-git
+pkgver=r13.1797ab5
+pkgrel=1
+pkgdesc="Thunderbolt Daemon from the Intel Thunderbolt Software Userspace"
+arch=('x86_64')
+url="https://github.com/01org/thunderbolt-software-user-space"
+license=('BSD')
+depends=('dbus-c++' 'libnl' 'thunderbolt-icm-dkms-git')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install='thunderboltd-git.install'
+source=('thunderboltd::git+https://github.com/01org/thunderbolt-software-user-space.git#branch=fwupdate'
+ '001_fix_sysmacros_include.patch'
+ '002_disable_postinstall.patch')
+md5sums=('SKIP'
+ '713ee1db7eea31db2cd5093c615225a3'
+ 'eb52425947438ed6f7f334bfe48f5066')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p0 -i "../../001_fix_sysmacros_include.patch"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/build"
+ cmake ../ThunderboltService/Linux -DCMAKE_BUILD_TYPE=Release
+ patch -p0 -i ../../../002_disable_postinstall.patch
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/thunderboltd-git.install b/thunderboltd-git.install
new file mode 100644
index 000000000000..2127de846a0a
--- /dev/null
+++ b/thunderboltd-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "To use the thunderbolt daemon the following steps are necessary:"
+ echo " 1) update udev rules: udevamd control --reload-rules"
+ echo " 2) load the thunderbolt-icm module: modprobe thunderbolt-icm"
+ echo " 3) start the thunderbolt service: systemctl start thunderboltd"
+}