summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lawson2015-08-04 00:14:35 +0100
committerMichael Lawson2015-08-04 00:14:35 +0100
commit10b107441b204193bd6e78ae2097d4a85310d9b9 (patch)
tree6072eabb6ae2b7ab1608b35a557a38a75ef211df
downloadaur-10b107441b204193bd6e78ae2097d4a85310d9b9.tar.gz
initial
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0d1d58859a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ibus-uniemoji-git
+ pkgdesc = A simple input method for ibus that allows you to enter unicode emoji and other symbols by name (git-version)
+ pkgver = 0.3.0.2.ga30c63f
+ pkgrel = 1
+ url = https://github.com/lalomartins/ibus-uniemoji
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = libibus
+ optdepends = python-levenshtein: faster fuzzy search
+ provides = ibus-uniemoji
+ source = git://github.com/lalomartins/ibus-uniemoji
+ md5sums = SKIP
+
+pkgname = ibus-uniemoji-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94875755f737
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Lawson <mdlawson@gmx.com>
+
+pkgname=ibus-uniemoji-git
+_gitname=ibus-uniemoji
+pkgver=0.3.0.2.ga30c63f
+pkgrel=1
+pkgdesc="A simple input method for ibus that allows you to enter unicode emoji and other symbols by name (git-version)"
+arch=(i686 x86_64)
+url="https://github.com/lalomartins/ibus-uniemoji"
+license=('MIT')
+depends=('python' 'libibus')
+makedepends=('git')
+provides=('ibus-uniemoji')
+optdepends=('python-levenshtein: faster fuzzy search')
+source=("git://github.com/lalomartins/ibus-uniemoji")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --tags | sed -e 's:v::' -e 's/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p $pkgdir/usr/share/ibus-uniemoji
+ cp uniemoji.py uniemoji.svg UnicodeData.txt $pkgdir/usr/share/ibus-uniemoji
+ chmod a+x $pkgdir/usr/share/ibus-uniemoji/uniemoji.py
+ mkdir -p $pkgdir/usr/share/ibus/component
+ cp uniemoji.xml $pkgdir/usr/share/ibus/component
+}