summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGimmeapill2024-02-18 19:22:40 +0100
committerGimmeapill2024-02-18 19:22:40 +0100
commit10e5dfb5ac3ffc1493bc80e742aad0f2873b4f24 (patch)
tree9e3616611df82bac31a15ff89e1e3bfcc022ca36
parentd6454861810856f60fbe18dc925bbd49b93d364c (diff)
downloadaur-10e5dfb5ac3ffc1493bc80e742aad0f2873b4f24.tar.gz
adding the changes from SpotlightKid
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD63
2 files changed, 50 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cac90eacbec7..552305284ccc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = guitarix.vst-git
- pkgdesc = virtual versatile amplification for Jack/Linux - vst3 wrapper
- pkgver = Latest.r0.gcf94bd3
+ pkgdesc = A virtual versatile amplification for Jack/Linux - vst3 wrapper
+ pkgver = v0.1.r1.gacbdd19
pkgrel = 1
url = https://github.com/brummer10/guitarix.vst
arch = x86_64
- groups = vst-plugins
+ groups = vst3-plugins
groups = pro-audio
license = GPL3
makedepends = git
@@ -17,6 +17,12 @@ pkgbase = guitarix.vst-git
makedepends = sassc
makedepends = pkgconfig
makedepends = webkit2gtk
+ depends = alsa-lib
+ depends = curl
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = libsigc++
depends = libsndfile
depends = lilv
depends = fftw
@@ -26,7 +32,10 @@ pkgbase = guitarix.vst-git
optdepends = vst3-host: for VST3 plugins
optdepends = gxplugins.lv2: for Guitarix LV2 plugins
provides = guitarix.vst
+ conflicts = guitarix.vst
source = guitarix.vst::git+https://github.com/brummer10/guitarix.vst
- md5sums = SKIP
+ source = guitarix::git+https://github.com/brummer10/guitarix.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = guitarix.vst-git
diff --git a/PKGBUILD b/PKGBUILD
index 1d4c0cab6218..8a7e42ca64b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,49 @@
# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
-
-pkgname=guitarix.vst-git
-pkgver=Latest.r0.gcf94bd3
+# Contributor: Christopher Arndt <aur at chrisarndt dot de>
+
+_pkgname=guitarix.vst
+pkgname=$_pkgname-git
+pkgver=v0.1.r1.gacbdd19
pkgrel=1
-pkgdesc="virtual versatile amplification for Jack/Linux - vst3 wrapper"
-arch=('x86_64')
-url="https://github.com/brummer10/guitarix.vst"
-license=('GPL3')
-groups=('vst-plugins' 'pro-audio')
-#depends=('liblrdf' 'libsndfile' 'lilv' 'boost-libs' 'fftw' 'freetype2' 'glibmm' 'avahi')
-depends=('libsndfile' 'lilv' 'fftw' 'freetype2' 'glibmm' 'avahi')
-#makedepends=('git' 'boost' 'eigen' 'gperf' 'intltool' 'ladspa' 'lv2' 'waf' 'sassc' 'pkgconfig' 'webkit2gtk' 'glib2')
-makedepends=('git' 'boost' 'eigen' 'gperf' 'intltool' 'lv2' 'waf' 'sassc' 'pkgconfig' 'webkit2gtk')
+pkgdesc='A virtual versatile amplification for Jack/Linux - vst3 wrapper'
+arch=(x86_64)
+url='https://github.com/brummer10/guitarix.vst'
+license=(GPL3)
+groups=(vst3-plugins pro-audio)
+depends=(alsa-lib curl gcc-libs glib2 glibc libsigc++ libsndfile lilv fftw freetype2 glibmm avahi)
+makedepends=(git boost eigen gperf intltool lv2 waf sassc pkgconfig webkit2gtk)
optdepends=(
'vst3-host: for VST3 plugins'
'gxplugins.lv2: for Guitarix LV2 plugins'
)
-provides=('guitarix.vst')
-source=("${pkgname%-*}::git+https://github.com/brummer10/guitarix.vst")
-md5sums=('SKIP')
-
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/brummer10/guitarix.vst"
+ 'guitarix::git+https://github.com/brummer10/guitarix.git')
+sha256sums=('SKIP' 'SKIP')
+
pkgver() {
- cd "${pkgname%-*}"
- git describe --long --tags | sed -r 's/^V//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd $_pkgname
+ (
+ set -o pipefail
+ git describe --long --tag --match 'v*' | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
-
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git submodule set-url guitarix "$srcdir"/guitarix
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
- cd "$srcdir/${pkgname%-*}"
- git submodule init
- git submodule update
- make
+ cd $_pkgname
+ make
}
-
+
package() {
- cd "$srcdir/${pkgname%-*}"
- make JUCE_VST3DESTDIR="$pkgdir/usr/lib/vst3/" install
+ cd $_pkgname
+ make JUCE_VST3DESTDIR="$pkgdir"/usr/lib/vst3 install
}