summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-04 18:02:30 +0200
committerneodarz2020-06-04 18:02:30 +0200
commit10ff2ffa5e7fd3a29debda0b6b015405ba039ead (patch)
tree1625bcd6de97e06b8f1460873f2183ae2c209426
downloadaur-10ff2ffa5e7fd3a29debda0b6b015405ba039ead.tar.gz
Inital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52004fbcb877
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-print
+ pkgdesc = Check for Print statements in python files.
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/jbkahn/flake8-print
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/JBKahn/flake8-print/archive/3.1.0.tar.gz
+ sha512sums = 7a83fbe95e0b69fc3490b7402d1172f916872e0b1fa073e42277c8413fec31486bc3d08483e5f9a2e70a565ad371aac72400323353d25c18d8561e204ae8bece
+
+pkgname = python-flake8-print
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fc05ac64efb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-print
+pkgname=python-$_pkgname
+
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="Check for Print statements in python files."
+
+url='https://github.com/jbkahn/flake8-print'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/JBKahn/$_pkgname/archive/$pkgver.tar.gz")
+sha512sums=('7a83fbe95e0b69fc3490b7402d1172f916872e0b1fa073e42277c8413fec31486bc3d08483e5f9a2e70a565ad371aac72400323353d25c18d8561e204ae8bece')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+