summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqbvt2023-08-18 12:03:40 +0200
committerqbvt2023-08-18 12:03:40 +0200
commit1103c9a84e236ab75e772b0f8dce3aa3ecbafbfe (patch)
treeedd706c834b264f4b9de56cef6242785cc10f6ec
parent6f92c9dd4ba704b3d95b2ca1bcf07a88aa0371ae (diff)
downloadaur-1103c9a84e236ab75e772b0f8dce3aa3ecbafbfe.tar.gz
fix compilation with gcc 13
-rw-r--r--.gitignore9
-rw-r--r--0001-import-stdio.patch24
-rw-r--r--PKGBUILD18
3 files changed, 46 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index fd652e02c857..3fcdd307a997 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,9 @@
+# Source repo
/libstrangle/*
-/libstrangle*pkg.tar.xz
+
+# Build files
+/src
+/pkg
+
+# Build package
+*.pkg.tar.zst
diff --git a/0001-import-stdio.patch b/0001-import-stdio.patch
new file mode 100644
index 000000000000..d79838a9d0dd
--- /dev/null
+++ b/0001-import-stdio.patch
@@ -0,0 +1,24 @@
+From cb50c2452b87b92467c477881b26df799f150c71 Mon Sep 17 00:00:00 2001
+From: qbvt <qbouvet@outlook.com>
+Date: Thu, 17 Aug 2023 23:31:22 +0200
+Subject: [PATCH] fix
+
+---
+ src/vulkan/overlay.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/vulkan/overlay.cpp b/src/vulkan/overlay.cpp
+index 39c93cd..d023bcf 100644
+--- a/src/vulkan/overlay.cpp
++++ b/src/vulkan/overlay.cpp
+@@ -25,6 +25,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <assert.h>
++#include <stdio.h>
+
+ #include <mutex>
+ #include <map>
+--
+2.41.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 3b1a6a5c32a8..a352f7c22d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@ _latest_release=0.1.1
pkgname=${_pkgname}-git
pkgdesc="Simple FPS Limiter"
-pkgver=0.1.1.r135.0273e31
-pkgrel=2
+pkgver=0.1.1.r136.7173538
+pkgrel=3
url='https://gitlab.com/torkel104/libstrangle'
arch=('x86_64')
depends=('lib32-gcc-libs' 'lib32-glibc' 'libglvnd' 'linux-api-headers' 'libx11' 'xorgproto')
@@ -17,8 +17,14 @@ makedepends=('git')
provides=('libstrangle')
conflicts=('libstrangle')
license=('GPL3')
-source=("git+https://gitlab.com/torkel104/libstrangle.git")
-sha256sums=('SKIP')
+source=(
+ "git+https://gitlab.com/torkel104/libstrangle.git"
+ "0001-import-stdio.patch"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd $_pkgname
@@ -30,7 +36,11 @@ pkgver() {
prepare() {
cd $_pkgname
+
sed -i -e '/ldconfig/d' makefile
+
+ # Necessary after GCC upgrade
+ git am "../0001-import-stdio.patch"
}
build() {