summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeal Wierslee2024-01-12 18:09:01 -0500
committerZeal Wierslee2024-01-12 18:09:01 -0500
commit111255f82d233e364ab9121ab9a12c6ee6aeb18a (patch)
tree78ea50370a54788f2a47d488fd526068aff199a2
parent99b95fec71a9ee826f02ae3deb328a35f4df903f (diff)
downloadaur-111255f82d233e364ab9121ab9a12c6ee6aeb18a.tar.gz
Build from source and update to v1.1.0
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c9e775cd8dc..9e88f0656ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Zeal Wierslee <zeal@wierslee.me>
pkgname=sugarjar
-pkgver=0.0.11
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="A git/github helper inspired by arcanist (and others)"
arch=('x86_64')
url="https://github.com/jaymzh/sugarjar"
license=('Apache')
depends=('git' 'hub' 'libxcrypt-compat' 'ruby' 'rubygems' 'ruby-mixlib-log' 'ruby-mixlib-shellout' 'ruby-pastel')
source=("https://github.com/jaymzh/sugarjar/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=("1706a82e75ef7ac0469b8f7e9f6d0105cf731cd77280079464c2cfe89f86bef9")
+sha256sums=("5a75fab10cfb1509ae9e7ee5cfced13afbfec19e44e5020acf4a219f9c04f79c")
package() {
local _gemdir="$(env -i ruby -e'puts Gem.default_dir')"
cd "$pkgname-$pkgver"
+
+ gem build \
+ --norc \
+ --output "${pkgname}-${pkgver}.gem" \
+ "${pkgname}.gemspec"
+
gem install \
+ --local \
--ignore-dependencies \
--no-user-install \
-i "${pkgdir}/${_gemdir}" \
@@ -24,6 +31,4 @@ package() {
# If you use RVM the shebang will use the `ruby_executable_hooks` from your RVM installation, not the system one.
# Since sugarjar is installed in the system ruby, we want it to use the correct install of ruby.
sed -i "s%/usr/bin/env ruby_executable_hooks%/usr/bin/ruby%" "$pkgdir/usr/bin/sj"
-
- rm "${pkgdir}/${_gemdir}/cache/${pkgname}-${pkgver}.gem"
}