summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-20 15:39:23 +0000
committerGrey Christoforo2016-01-20 15:39:23 +0000
commit1123aa4c1b038f51af688664c974ec6c7eb01c2d (patch)
treee5003c82825ef429bd9da954aed26ce74d22c50b
parentf0324b5671c7e9853a2c1795c9086f7834012fe1 (diff)
downloadaur-1123aa4c1b038f51af688664c974ec6c7eb01c2d.tar.gz
initial working commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
-rw-r--r--homer.install3
-rwxr-xr-xhomer.sh2
5 files changed, 40 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7700747c3f3..5e86fbd3fb22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 11:31:34 UTC 2016
+# Wed Jan 20 15:38:04 UTC 2016
pkgbase = homer
pkgdesc = Hypergeometric Optimization of Motif EnRichment
pkgver = 4.8
pkgrel = 1
url = http://homer.salk.edu/
+ install = homer.install
arch = i686
arch = x86_64
license = GPLv3
depends = perl
- depends = weblogo
+ depends = weblogo2
depends = wget
optdepends = ucsc-kent-genome-tools: for the blat tool, required for removing redundant sequences during motif finding
optdepends = ghostscript: required for making motif logos
- source = http://homer.salk.edu/homer/configureHomer.pl
- md5sums = f0f52cfe22bfe341532a11d947aac803
+ source = http://homer.salk.edu/homer/data/software/homer.v4.8.zip
+ source = homer.sh
+ md5sums = 173c9ad0e35d7639b89331de87505928
+ md5sums = 81a149ed531dcca7f0096901fd88ddeb
pkgname = homer
diff --git a/.gitignore b/.gitignore
index 3ea950438567..d060381623c1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
pkg/
src/
*.pl
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 473e8b21ca75..5b856392f3f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,41 @@ arch=('i686' 'x86_64')
license=('GPLv3')
optdepends=('ucsc-kent-genome-tools: for the blat tool, required for removing redundant sequences during motif finding'
'ghostscript: required for making motif logos')
-depends=('perl' 'weblogo' 'wget')
-source=("http://homer.salk.edu/homer/configureHomer.pl")
-md5sums=('f0f52cfe22bfe341532a11d947aac803')
-#options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
+depends=('perl' 'weblogo2' 'wget')
+source=("http://homer.salk.edu/homer/data/software/homer.v${pkgver}.zip" "homer.sh")
+md5sums=('173c9ad0e35d7639b89331de87505928'
+ '81a149ed531dcca7f0096901fd88ddeb')
+install=('homer.install')
prepare(){
-msg "preparing"
+ cd ${srcdir}/cpp
+ make clean
}
build(){
-msg "building"
+ #cd ${srcdir}
+ #perl configureHomer.pl -install homer
+
+ cd ${srcdir}/cpp
+ make # this actually also copies the exes to bin/ then clean can't clean them
+ make clean
}
package() {
-msg "packaging"
+ # just put everything into opt
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -a ${srcdir}/* "${pkgdir}/opt/${pkgname}/."
+
+ # link the main perl script
+ mkdir -p ${pkgdir}/usr/bin
+ chmod 755 "${pkgdir}/opt/${pkgname}/configureHomer.pl"
+ ln -s /opt/${pkgname}/configureHomer.pl ${pkgdir}/usr/bin/.
+
+ # install profile file
+ install -m755 -D "${srcdir}/homer.sh" -t "${pkgdir}/etc/profile.d"
+
+ # install license file
+ install -m644 -D "${srcdir}/COPYING" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et:#
diff --git a/homer.install b/homer.install
new file mode 100644
index 000000000000..5ac33ab1ec23
--- /dev/null
+++ b/homer.install
@@ -0,0 +1,3 @@
+post_install() {
+ source /etc/profile
+}
diff --git a/homer.sh b/homer.sh
new file mode 100755
index 000000000000..e3a6f225d82c
--- /dev/null
+++ b/homer.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+PATH="$PATH:/opt/homer/bin"