summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-06-17 18:56:40 -0300
committerFilipe Nascimento2020-06-17 18:56:40 -0300
commit112414bb02d878f0edb3b436fff45003c7580e7e (patch)
treeef520e7ddebea3aa0f52142456bb4707616e251c
downloadaur-112414bb02d878f0edb3b436fff45003c7580e7e.tar.gz
Initial upload: choose 1.2.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e6fae152fef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = choose
+ pkgdesc = A human-friendly and fast alternative to cut and (sometimes) awk
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/theryangeary/choose
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ depends = gcc-libs
+ source = choose-1.2.0.tar.gz::https://github.com/theryangeary/choose/archive/v1.2.0.tar.gz
+ sha256sums = 5711a301e8cc7a5f257773feef992ce8da714a9ee167f234943203ee36c923ad
+
+pkgname = choose
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa3f32293262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Filipe Nascimento <flipee at tuta dot io>
+
+pkgname=choose
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A human-friendly and fast alternative to cut and (sometimes) awk"
+arch=('x86_64')
+url="https://github.com/theryangeary/choose"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('5711a301e8cc7a5f257773feef992ce8da714a9ee167f234943203ee36c923ad')
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release --locked
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+}