summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0b1001002021-10-06 03:59:40 +0200
committer0b1001002021-10-06 03:59:40 +0200
commit11385b425856067252d8faa19d46fe9f2f1bc7f1 (patch)
tree54af92174eb9d45984111c0baf351f1d8323b6f6
parent75d4bdd2b69b051b933823e890627433367a1c7a (diff)
downloadaur-11385b425856067252d8faa19d46fe9f2f1bc7f1.tar.gz
Add check function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47655101cd31..62d1b23d3f78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = python-binance-git
url = https://github.com/sammchardy/python-binance
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-requests-mock
makedepends = git
makedepends = python-setuptools
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 7e1b696b6de3..f0610ba28eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,10 @@ license=('MIT')
depends=('python' 'python-aiohttp' 'python-dateparser'
'python-requests' 'python-ujson' 'python-websockets=9.1')
makedepends=('git' 'python-setuptools')
+checkdepends=('python-pytest' 'python-requests-mock')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/sammchardy/$_pkgname.git")
+source=("git+$url.git")
sha512sums=('SKIP')
pkgver() {
@@ -28,6 +29,11 @@ build() {
python setup.py build
}
+check() {
+ cd $_pkgname
+ pytest
+}
+
package() {
cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1 --skip-build