summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-06-24 13:05:59 +0200
committerMaxime Gauduin2018-06-24 13:05:59 +0200
commit11417d817c917cc41417980ab31ef56b331cf196 (patch)
treed89082fffd881dc82b13e0ae859f6065c956c90a
parent2f8b9bd1ff7b93fd780a78e67de41638e7a19465 (diff)
downloadaur-11417d817c917cc41417980ab31ef56b331cf196.tar.gz
Switch to meson
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b22e33a1b33..75854b7bc80c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jun 19 14:07:22 UTC 2018
+# Wed Jan 10 16:42:15 UTC 2018
pkgbase = wingpanel-indicator-privacy-git
pkgdesc = Privacy indicator for Wingpanel
pkgver = r68.4a3abae
@@ -8,9 +8,9 @@ pkgbase = wingpanel-indicator-privacy-git
arch = x86_64
groups = pantheon-unstable
license = GPL3
+ makedepends = cmake
makedepends = git
makedepends = granite-git
- makedepends = meson
makedepends = vala
makedepends = wingpanel-git
depends = bamf
diff --git a/PKGBUILD b/PKGBUILD
index 6214d15148d1..cc1ebaebac0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('bamf' 'glib2' 'glibc' 'gtk3' 'libgee' 'libgtop' 'lsof'
'libwingpanel-2.0.so')
-makedepends=('git' 'granite-git' 'meson' 'vala' 'wingpanel-git')
+makedepends=('cmake' 'git' 'granite-git' 'vala' 'wingpanel-git')
provides=('wingpanel-indicator-privacy')
conflicts=('wingpanel-indicator-privacy')
source=('git+https://github.com/elementary/wingpanel-indicator-privacy.git')
@@ -22,13 +22,27 @@ pkgver() {
echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
build() {
- arch-meson wingpanel-indicator-privacy build
- ninja -C build
+ cd build
+
+ cmake ../wingpanel-indicator-privacy \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ cd build
+
+ make DESTDIR="${pkgdir}" install
}
# vim: ts=2 sw=2 et: