summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Horna2020-12-27 03:44:40 -0500
committerBryan Horna2020-12-27 03:44:40 -0500
commit116ea70dcfc9bc6ac1aca379f23c1c61acf9552a (patch)
tree9ec6647f0614fca59ad3ea1574baf7602ee0c5b3
parentb2bd33ef6a7c507524f4526d2496d4cc1432c41c (diff)
downloadaur-116ea70dcfc9bc6ac1aca379f23c1c61acf9552a.tar.gz
Bring back multiarch support
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD85
-rw-r--r--libxcrypt.patch23
3 files changed, 89 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9df21536ae19..d966ef4b049a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,42 @@
pkgbase = asleap
pkgdesc = Actively recover LEAP/PPTP passwords.
pkgver = 2.2
- pkgrel = 4
- url = http://www.willhackforsushi.com/Asleap.html
+ pkgrel = 5
+ url = https://www.willhackforsushi.com/?page_id=41
arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
- depends = openssl
depends = libpcap
+ depends = openssl
noextract = libxcrypt1.deb
noextract = libxcrypt-dev.deb
- noextract = libxcrypt.patch
- source = http://www.willhackforsushi.com/code/asleap/2.2/asleap-2.2.tgz
- source = libxcrypt1.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
- source = libxcrypt-dev.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
+ source = https://www.willhackforsushi.com/code/asleap/2.2/asleap-2.2.tgz
source = libxcrypt.patch
md5sums = a1d06729fb2addcc5b09bfc14f9b3173
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = cb9cf76a3e7bee1e546ce9a982b0f912
+ source_x86_64 = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
+ source_x86_64 = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
+ md5sums_x86_64 = SKIP
+ md5sums_x86_64 = SKIP
+ source_i686 = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_i386.deb
+ source_i686 = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_i386.deb
+ md5sums_i686 = SKIP
+ md5sums_i686 = SKIP
+ source_armv6h = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_armel.deb
+ source_armv6h = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_armel.deb
+ md5sums_armv6h = SKIP
+ md5sums_armv6h = SKIP
+ source_armv7h = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_armhf.deb
+ source_armv7h = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_armhf.deb
+ md5sums_armv7h = SKIP
+ md5sums_armv7h = SKIP
+ source_aarch64 = libxcrypt1.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt1_2.4-4_arm64.deb
+ source_aarch64 = libxcrypt-dev.deb::http://ftp.debian.org/debian/pool/main/libx/libxcrypt/libxcrypt-dev_2.4-4_arm64.deb
+ md5sums_aarch64 = SKIP
+ md5sums_aarch64 = SKIP
pkgname = asleap
diff --git a/PKGBUILD b/PKGBUILD
index 28a1fd254613..f20c03d98440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,61 @@
-# Contributors:
-# henning mueller <henning@orgizm.net>
+# Maintainer: Bryan Horna <bryanjhv@gmail.com>
+# Contributor: Henning Mueller <henning@orgizm.net>
pkgname=asleap
pkgver=2.2
-pkgrel=4
-pkgdesc='Actively recover LEAP/PPTP passwords.'
-arch=(x86_64)
-license=(GPL)
-url=http://www.willhackforsushi.com/Asleap.html
-depends=(openssl libpcap)
-source=(
- http://www.willhackforsushi.com/code/asleap/$pkgver/asleap-$pkgver.tgz
- libxcrypt1.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt1_2.4-4_amd64.deb
- libxcrypt-dev.deb::http://mirrors.kernel.org/ubuntu/pool/universe/libx/libxcrypt/libxcrypt-dev_2.4-4_amd64.deb
- libxcrypt.patch
-)
-noextract=(
- libxcrypt1.deb
- libxcrypt-dev.deb
- libxcrypt.patch
-)
-md5sums=(
- a1d06729fb2addcc5b09bfc14f9b3173
- SKIP
- SKIP
- SKIP
-)
+pkgrel=5
+pkgdesc="Actively recover LEAP/PPTP passwords."
+arch=("x86_64" "i686" "armv6h" "armv7h" "aarch64")
+url="https://www.willhackforsushi.com/?page_id=41"
+license=("GPL")
+depends=("libpcap" "openssl")
+source=("https://www.willhackforsushi.com/code/$pkgname/$pkgver/$pkgname-$pkgver.tgz"
+ "libxcrypt.patch")
+noextract=("libxcrypt1.deb"
+ "libxcrypt-dev.deb")
+md5sums=("a1d06729fb2addcc5b09bfc14f9b3173"
+ "cb9cf76a3e7bee1e546ce9a982b0f912")
+
+# Dynamically generate sources and skip sums
+_arch=("amd64" "i386" "armel" "armhf" "arm64")
+_repo="http://ftp.debian.org/debian/pool/main/libx/libxcrypt/"
+_vers="2.4-4"
+_pkgs=("libxcrypt1" "libxcrypt-dev")
+for _i in "${!arch[@]}"; do
+ _darch="${arch[$_i]}"
+ _sarch="${_arch[$_i]}"
+ eval "source_$_darch"=\(\)
+ eval "md5sums_$_darch"=\(\)
+ for _p in "${_pkgs[@]}"; do
+ eval "md5sums_$_darch"+=\("SKIP"\)
+ eval "source_$_darch"+=\("$_p.deb::$_repo${_p}_${_vers}_$_sarch.deb"\)
+ done
+done
prepare() {
- mkdir deb
- ar p libxcrypt1.deb data.tar.xz | tar xJC deb
- ar p libxcrypt-dev.deb data.tar.xz | tar xJC deb
+ mkdir deb
+ for _p in "${_pkgs[@]}"; do
+ ar p "$_p.deb" data.tar.xz | tar xJC deb
+ done
+ ln -sfr deb/lib/libxcrypt.so.1 deb/lib/libxcrypt.so
- cd $srcdir/asleap-$pkgver
- patch --forward --strip=1 --input="${srcdir}/libxcrypt.patch"
+ cd "$pkgname-$pkgver"
+ patch -Nup1 -i "$srcdir/libxcrypt.patch"
}
build() {
- cd $srcdir/asleap-$pkgver
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd $srcdir/asleap-$pkgver
- install -D asleap $pkgdir/usr/bin/asleap
- install -D genkeys $pkgdir/usr/bin/genkeys
+ cd "$pkgname-$pkgver"
+ install -D asleap "$pkgdir/usr/bin/asleap"
+ install -D genkeys "$pkgdir/usr/bin/genkeys"
- cd $srcdir/deb
- install -dv $pkgdir/usr/lib
- mv lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib
- ln -s /usr/lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib/libxcrypt.so
- ln -s /usr/lib/libxcrypt.so.1.2.4 $pkgdir/usr/lib/libxcrypt.so.1
+ cd "$srcdir/deb"
+ _so=lib/libxcrypt.so.1.2.4
+ install -D $_so -t "$pkgdir/usr/lib"
+ ln -s /usr/$_so "$pkgdir/usr/lib/libxcrypt.so"
+ ln -s /usr/$_so "$pkgdir/usr/lib/libxcrypt.so.1"
}
diff --git a/libxcrypt.patch b/libxcrypt.patch
index 1834bb4d5902..6cb51b5d81bc 100644
--- a/libxcrypt.patch
+++ b/libxcrypt.patch
@@ -1,23 +1,28 @@
-diff --unified --recursive --text --color asleap-2.2/Makefile asleap-2.2-new/Makefile
+diff -Naur asleap-2.2/Makefile asleap-2.2-new/Makefile
--- asleap-2.2/Makefile 2007-07-13 20:00:58.000000000 -0500
-+++ asleap-2.2-new/Makefile 2020-12-19 21:38:02.071555347 -0500
-@@ -7,10 +7,12 @@
++++ asleap-2.2-new/Makefile 2020-12-27 03:33:49.819887649 -0500
+@@ -6,12 +6,14 @@
+ # <dragorn> heh
# <dragorn> i think thats all anyone does
# <dragorn> make is a twisted beast
++# <bryanjhv> pull https://github.com/joswr1ght/asleap/commit/4576d14
##################################
-LDLIBS = -lpcap -lcrypt
+-CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
+-CFLAGS += -D_OPENSSL_MD4
+LDLIBS = -lpcap -lxcrypt
- CFLAGS = -pipe -Wall -D_LINUX -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../../..
- CFLAGS += -D_OPENSSL_MD4
++CFLAGS = -pipe -Wall -D_LINUX -D_OPENSSL_MD4
LDLIBS += -lcrypto
-+LDLIBS += -L"../deb/usr/lib"
+-CFLAGS += -g3 -ggdb -g
++CFLAGS += -g3 #-ggdb -g
++LDLIBS += -L"../deb/lib"
+CFLAGS += -I"../deb/usr/include"
- CFLAGS += -g3 -ggdb -g
PROGOBJ = asleap.o genkeys.o utils.o common.o sha1.o
PROG = asleap genkeys
-diff --unified --recursive --text --color asleap-2.2/utils.c asleap-2.2-new/utils.c
+
+diff -Naur asleap-2.2/utils.c asleap-2.2-new/utils.c
--- asleap-2.2/utils.c 2007-07-13 20:00:58.000000000 -0500
-+++ asleap-2.2-new/utils.c 2020-12-19 21:30:14.418336923 -0500
++++ asleap-2.2-new/utils.c 2020-12-27 03:26:18.439970818 -0500
@@ -27,7 +27,7 @@
#include <stdarg.h>
#include <string.h>