summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Rubio2021-12-31 12:26:30 +0100
committerMario Rubio2021-12-31 12:26:30 +0100
commit117a6b7187be5eb95d7ba5b75e1ba5756586a431 (patch)
tree2a490f1167cba6571f11a190765cc879d7d69147
parente5295ec734d4f6f98f8fdeb6848f46eed9c7a6c1 (diff)
downloadaur-117a6b7187be5eb95d7ba5b75e1ba5756586a431.tar.gz
Digilent Adept Utilities 2.7.1
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dedd4d50f094..a1834da5a006 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: Amr Okasha <amradel55 at gmail dot com>
-# Contributer: Knight <anonymousknight96 at gmail dot com>
+# Maintainer: Mario Rubio <mario at mrrb dot eu>
+# Contributor: Amr Okasha <amradel55 at gmail dot com>
+# Contributor: Knight <anonymousknight96 at gmail dot com>
pkgname=digilent.adept.utilities
-pkgver=2.4.1
+pkgver=2.7.1
pkgrel=1
pkgdesc="Digilent Adept Utilities."
-arch=('i686' 'x86_64')
-url="https://reference.digilentinc.com/digilent_adept_2"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://digilent.com/reference/software/adept/start"
license=('custom')
depends=('digilent.adept.runtime>=2.21.2')
options=('!strip' '!emptydirs')
-source_x86_64=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
+
source_i686=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-i386.deb")
-sha256sums_i686=('fa4b2f7c9c08c302e177142162497487d3b27cbc7136010f012cb3e3e9c1edc3')
-sha256sums_x86_64=('a05d2c13df1639e92aa96f4532b1990ef1166059bd361da0259d5b0cca3c7be6')
+source_x86_64=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
+source_aarch64=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-arm64.deb")
+sha256sums_i686=('954ef56e3e702dde125a404336ecc886e02b3b8fe0adea30608b14745feef4e9')
+sha256sums_x86_64=('efbfc97b69fa6d6dc465991492dceb308ef9ea220e185bcfd12f0b7494465842')
+sha256sums_aarch64=('f8dc86b30c456a83ed0e588a9f719a3a3d1b4bf7a27e8ef729c00387b875e261')
package(){
-
# Extract package data
tar -xJf data.tar.xz -C "${pkgdir}"/
install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s "/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
- ln -s "/usr/share/doc/${pkgname}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
-
+ ln -s "/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+ ln -s "/usr/share/doc/${pkgname}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
}