summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrmaxmeier2016-08-06 17:54:48 +0200
committerMrmaxmeier2016-08-06 18:58:46 +0200
commit1185c2196a27e0c69211a5edc8ba58a1dea075cd (patch)
treef240f9671e184b69b1907a60b57c6e29618f6c98
downloadaur-1185c2196a27e0c69211a5edc8ba58a1dea075cd.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
-rw-r--r--bombsquad.desktop11
-rw-r--r--bombsquad.sh3
5 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6b1b795245e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = bombsquad
+ pkgdesc = An explosive arcade-style party game
+ pkgver = 1.4.96
+ pkgrel = 1
+ url = http://www.froemling.net/apps/bombsquad
+ arch = x86_64
+ arch = i686
+ license = unknown
+ depends = openal
+ depends = libgl
+ depends = sdl2
+ depends = gcc
+ depends = libvorbis
+ depends = libogg
+ depends = libxau
+ source = bombsquad.sh
+ sha256sums = 850f8a66eb045ce833f8d7dae4533f69b629ac648bd205d98bf5f851339d4515
+ source_x86_64 = http://www.files.froemling.net/bombsquad/builds/BombSquad_Linux_64bit_1.4.96.tar.gz
+ sha256sums_x86_64 = cbcd5cdfe7358622ea84dd31a6659b137a65e48609173eb0f10879b97fad70d4
+ source_i686 = http://www.files.froemling.net/bombsquad/builds/BombSquad_Linux_32bit_1.4.96.tar.gz
+ sha256sums_i686 = dc784e03b9f83d88dafacff6caf3be18968939cb57a026141b8d8b6efcd319e2
+
+pkgname = bombsquad
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a7eaf3d37c7b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..207917e3f45a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mrmaxmeier <Mrmaxmeier+aur at gmail dot com>
+# TODO: dynamically choose between /builds/.. and /builds/old/..
+
+pkgname=bombsquad
+pkgver=1.4.96
+pkgrel=1
+pkgdesc='An explosive arcade-style party game'
+arch=('x86_64' 'i686')
+url='http://www.froemling.net/apps/bombsquad'
+license=('unknown')
+depends=('openal' 'libgl' 'sdl2' 'gcc' 'libvorbis' 'libogg' 'libxau')
+source=("bombsquad.sh")
+sha256sums=('850f8a66eb045ce833f8d7dae4533f69b629ac648bd205d98bf5f851339d4515')
+
+source_i686=("http://www.files.froemling.net/bombsquad/builds/BombSquad_Linux_32bit_${pkgver}.tar.gz")
+sha256sums_i686=('dc784e03b9f83d88dafacff6caf3be18968939cb57a026141b8d8b6efcd319e2')
+
+source_x86_64=("http://www.files.froemling.net/bombsquad/builds/BombSquad_Linux_64bit_${pkgver}.tar.gz")
+sha256sums_x86_64=('cbcd5cdfe7358622ea84dd31a6659b137a65e48609173eb0f10879b97fad70d4')
+
+
+package() {
+ case "$CARCH" in
+ x86_64)
+ cd "$srcdir"/BombSquad_Linux_64bit_"$pkgver"
+ ;;
+ i686)
+ cd "$srcdir"/BombSquad_Linux_32bit_"$pkgver"
+ ;;
+ esac
+
+ install -Dm755 bombsquad "$pkgdir"/usr/share/bombsquad/bombsquad
+ install -dm755 data "$pkgdir"/usr/share/bombsquad/data
+ cp -r data "$pkgdir"/usr/share/bombsquad/
+
+ find "${pkgdir}/usr/share/bombsquad/data" -type f -exec chmod 644 {} \;
+ find "${pkgdir}/usr/share/bombsquad/data" -type d -exec chmod 755 {} \;
+
+ install -Dm 755 "$srcdir"/bombsquad.sh "$pkgdir"/usr/bin/$pkgname
+}
+
+
diff --git a/bombsquad.desktop b/bombsquad.desktop
new file mode 100644
index 000000000000..ff3964012779
--- /dev/null
+++ b/bombsquad.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=BombSquad
+Comment=An explosive arcade-style party game.
+Exec=bombsquad
+Encoding=UTF-8
+Icon=/usr/share/pixmaps/bombsquad.png
+Categories=Game;ArcadeGame;
+Terminal=false
+StartupNotify=false
diff --git a/bombsquad.sh b/bombsquad.sh
new file mode 100644
index 000000000000..82291fc8ed7c
--- /dev/null
+++ b/bombsquad.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /usr/share/bombsquad
+./bombsquad \ No newline at end of file