summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAidan Harris2016-11-28 03:38:22 +0000
committerAidan Harris2016-11-28 03:38:22 +0000
commit118bff2c8f05ae91830876d95ac58b1baeae0011 (patch)
tree915f81dc02032553d3f961f4c71507387aae77b2
downloadaur-118bff2c8f05ae91830876d95ac58b1baeae0011.tar.gz
Initial Commit (v0.4.7)
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD44
-rw-r--r--alkasir-client.install14
-rw-r--r--alkasir-client.service12
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d143fc5d655
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Nov 28 03:32:19 UTC 2016
+pkgbase = alkasir-client
+ pkgdesc = Alkasir is a cross-platform, open-source and robust website censorship circumvention tool that also maps censorship patterns around the world.
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = https://alkasir.com/
+ install = alkasir-client.install
+ arch = x86_64
+ license = custom:https://alkasir.com/en/License.html
+ makedepends = links
+ depends = glibc
+ optdepends = google-chrome
+ optdepends = google-chrome-beta
+ optdepends = google-chrome-dev
+ optdepends = chromium
+ source = https://github.com/alkasir/alkasir/releases/download/0.4.7/alkasir-client_linux-amd64.tar.gz
+ source = alkasir-client.service
+ md5sums = 8490b46497d51de548341cf81d7989ee
+ md5sums = 741b2eee3c554d555f932cf0011da922
+
+pkgname = alkasir-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d53a025fedf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: ahrs <Forward dot to at hotmail dot co dot uk>
+
+pkgname='alkasir-client'
+pkgver=0.4.7
+pkgrel=1
+arch=('x86_64')
+_arch="amd64" # Change to '386' to install the 32 bit client
+url="https://alkasir.com/"
+depends=('glibc')
+makedepends=('links') # Links is needed to download the license agreement
+optdepends=('google-chrome'
+ 'google-chrome-beta'
+ 'google-chrome-dev'
+ 'chromium'
+)
+licenseURL='https://alkasir.com/en/License.html'
+license=("custom:$licenseURL")
+pkgdesc="Alkasir is a cross-platform, open-source and robust website censorship circumvention tool that also maps censorship patterns around the world."
+source=("https://github.com/alkasir/alkasir/releases/download/$pkgver/alkasir-client_linux-$_arch.tar.gz"
+ "alkasir-client.service")
+md5sums=('8490b46497d51de548341cf81d7989ee'
+ '741b2eee3c554d555f932cf0011da922'
+)
+install="alkasir-client.install"
+
+_pkgarchive="alkasir-client-linux-$_arch"
+
+prepare() {
+ # The client currently isn't distributed with a license so we download it from the web...
+ if [ ! -f "$srcdir/$_pkgarchive/LICENSE" ]
+ then
+ links -dump "$licenseURL" > "$srcdir/$_pkgarchive/LICENSE"
+ fi
+}
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname-linux-$_arch"
+
+ cp -a "$srcdir/$_pkgarchive/." "$pkgdir/opt/$pkgname-linux-amd64/"
+
+ install -D -m644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/user/$pkgname.service"
+
+ install -D -m644 "$srcdir/$_pkgarchive/LICENSE" "$pkgdir/usr/share/licenses/$_pkgarchive/LICENSE"
+}
diff --git a/alkasir-client.install b/alkasir-client.install
new file mode 100644
index 000000000000..793d91cf748b
--- /dev/null
+++ b/alkasir-client.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_upgrade
+ echo ">>> Run the daemon as your user as follows:"
+ echo ">>> systemctl --user daemon-reload"
+ echo ">>> systemctl start --user alkasir-client"
+ echo ">>> journalctl --user -u alkasir-client"
+}
+
+post_upgrade() {
+ # This won't work with the 32bit version
+ # To Do:
+ # * Fix Me
+ chown -R root:root /opt/alkasir-client-linux-amd64
+}
diff --git a/alkasir-client.service b/alkasir-client.service
new file mode 100644
index 000000000000..4beac4eb83eb
--- /dev/null
+++ b/alkasir-client.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Alkasir Client Service
+
+[Service]
+# Won't work with 32bit version
+# To Do:
+# * Fix Me
+ExecStart=/opt/alkasir-client-linux-amd64/alkasir-client_linux_amd64
+Restart=on-failure
+
+[Install]
+WantedBy=default.target