summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgi Kobakhidze2024-02-02 13:05:16 +0400
committerGiorgi Kobakhidze2024-02-02 13:08:40 +0400
commit11d039fc285a917da270dd3f1fb77e8e96067787 (patch)
tree29d734ef5ff7aa93022de322d76975bb0a64f1b8
parent6c82380b284df22aeb76e3d488f1bc9438062c05 (diff)
downloadaur-11d039fc285a917da270dd3f1fb77e8e96067787.tar.gz
shellcheck fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--makefile-shellcheck-configure.patch11
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77d8c9e767e8..cb1094f6fa65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prosody-hg
pkgdesc = Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)
- pkgver = r11977+.10cdfb94f1cc+
+ pkgver = r13414+.d54364746a7c+
pkgrel = 1
url = https://prosody.im/
install = prosody.install
@@ -27,9 +27,11 @@ pkgbase = prosody-hg
source = prosody.tmpfile.d
source = sysuser.conf
source = prosody.service
+ source = makefile-shellcheck-configure.patch
sha256sums = SKIP
sha256sums = fb025d8d0608dc9fd5be2fde8528bc4fa10d9e38874a98eaa5c56ca9ae048302
sha256sums = e5c30ffbb066f0ed3444475b3313490c535d8c9df018726f6cecf9e3ddfd2e48
sha256sums = 40ea4a388ba69568daedde69b636d54747be1452e9d485fe19ee23320e66ada2
+ sha256sums = 88a8d155b48217182c0d1c9f58b0c8479e130143b3e28e88d93b60ea77c73b2a
pkgname = prosody-hg
diff --git a/PKGBUILD b/PKGBUILD
index 38ae94a928d4..781d34c9c954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=prosody-hg
pkgrel=1
-pkgver=r11977+.10cdfb94f1cc+
+pkgver=r13414+.d54364746a7c+
pkgdesc="Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)"
arch=('i686' 'x86_64' 'armv7h')
url="https://prosody.im/"
@@ -32,7 +32,8 @@ backup=('etc/prosody/prosody.cfg.lua')
source=("prosody-hg::hg+https://hg.prosody.im/trunk"
'prosody.tmpfile.d'
'sysuser.conf'
- 'prosody.service')
+ 'prosody.service'
+ makefile-shellcheck-configure.patch)
pkgver() {
cd "$srcdir/$pkgname"
@@ -42,6 +43,8 @@ pkgver() {
prepare() {
cd ${pkgname}
+ patch -l < "$srcdir"/makefile-shellcheck-configure.patch
+
# disable logging to output and activate syslog
sed -i s/"info = "/"-- info = "/g prosody.cfg.lua.dist
sed -i s/"error = "/"-- error = "/g prosody.cfg.lua.dist
@@ -87,4 +90,5 @@ package() {
sha256sums=('SKIP'
'fb025d8d0608dc9fd5be2fde8528bc4fa10d9e38874a98eaa5c56ca9ae048302'
'e5c30ffbb066f0ed3444475b3313490c535d8c9df018726f6cecf9e3ddfd2e48'
- '40ea4a388ba69568daedde69b636d54747be1452e9d485fe19ee23320e66ada2')
+ '40ea4a388ba69568daedde69b636d54747be1452e9d485fe19ee23320e66ada2'
+ 88a8d155b48217182c0d1c9f58b0c8479e130143b3e28e88d93b60ea77c73b2a)
diff --git a/makefile-shellcheck-configure.patch b/makefile-shellcheck-configure.patch
new file mode 100644
index 000000000000..b0f19e3a1a37
--- /dev/null
+++ b/makefile-shellcheck-configure.patch
@@ -0,0 +1,11 @@
+--- - 2023-06-25 07:14:36.641047783 +0400
++++ makefile 2023-06-25 06:52:52.458396110 +0400
+@@ -102,7 +102,7 @@
+ lint:
+ $(LUACHECK) -q $$(HGPLAIN= hg files -I '**.lua') prosody prosodyctl
+ @echo $$(sed -n '/^\tlocal exclude_files/,/^}/p;' .luacheckrc | sed '1d;$d' | wc -l) files ignored
+- shellcheck configure
++ shellcheck - < configure
+
+ test:
+ $(BUSTED) --lua=$(RUNWITH)