summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrizio del Tin2020-12-24 20:33:31 +0100
committerFabrizio del Tin2020-12-24 20:33:31 +0100
commit120498b29f23adceed91aab581faf94928d93bb8 (patch)
tree615ccc9d254775752ffee783af03414156c44548
parenta034b6e32b85b8a3bb0518afcfc51433f3b01775 (diff)
downloadaur-120498b29f23adceed91aab581faf94928d93bb8.tar.gz
Updated to package version 15620
-rw-r--r--.SRCINFO74
-rw-r--r--PKGBUILD117
2 files changed, 52 insertions, 139 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5853e7299ad..2c0af742802f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,70 +1,36 @@
-# Generated by mksrcinfo v8
-# Sun Jan 1 03:16:56 UTC 2017
-pkgbase = upp-nightly
- pkgdesc = Radical and innovative multiplatform C++ framework (known as U++) — nightly build
- pkgver = 10611
+pkgbase = upp
+ pkgdesc = Radical and innovative multiplatform C++ framework (known as U++)
+ pkgver = 15620
pkgrel = 1
url = http://www.ultimatepp.org
arch = any
license = BSD
- depends = gtk2
+ depends = gcc
+ depends = make
+ depends = zlib
+ depends = bzip2
+ depends = gtk3
depends = libnotify
- depends = libpng
- depends = gcc-libs
- depends = libxft
- depends = desktop-file-utils
- optdepends = libnotify: Enables compiling gtk-styled apps
- optdepends = sox: Enables playing notification sounds
+ depends = openssl
+ depends = clang
+ depends = pkgconfig
+ depends = gdb
+ conflicts = upp
+ conflicts = theide
+ conflicts = umk
options = !makeflags
options = emptydirs
options = !strip
- source = http://www.ultimatepp.org/downloads/upp-x11-src-10611.tar.gz
- source = GCC.bm
- source = license.txt
- source = theide.install
- source = https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/theide.1
- source = https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/umk.1
- source = https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/mkfile
- md5sums = SKIP
- md5sums = a1b57c2231b6b0fa8070941fa4accf72
- md5sums = b214709f096e4f50d61f50988359241e
- md5sums = 204e9ece27294b4b73cb3a31f0474d8d
- md5sums = b21415926edc5f18efaec625f6135556
- md5sums = b56d54a9d5d722bb32633a06675fbeb6
- md5sums = 9ad99eb6ead298341b6698e505067d7c
+ source = https://www.ultimatepp.org/downloads/upp-posix-15620.tar.xz
+ md5sums = 6ca4ff0e5aef7ed29f89304718eb5f09
pkgname = upp-nightly
- pkgdesc = Radical and innovative multiplatform C++ framework (known as U++) — nightly build
- arch = any
+ pkgdesc = Radical and innovative multiplatform C++ framework (known as U++)
depends = theide-nightly
- optdepends = libnotify: Enables compiling gtk-styled apps
- provides = upp
- conflicts = upp
- options = emptydirs
- options = !strip
pkgname = theide-nightly
- pkgdesc = Modern IDE designed for developping large U++/C++ applications — nightly build
- install = theide.install
- arch = i686
- arch = x86_64
- depends = gtk2
- depends = libnotify
- depends = desktop-file-utils
- optdepends = sox: Enables notification sounds
- provides = theide
- conflicts = theide
- options = !makeflags
- options = emptydirs
+ pkgdesc = Modern IDE designed for developing large U++/C++ applications
pkgname = umk-nightly
- pkgdesc = Command line builder for U++ applications — nightly build
- arch = i686
- arch = x86_64
- depends = gcc-libs
- depends = desktop-file-utils
- provides = umk
- conflicts = umk
- options = !makeflags
- options = emptydirs
+ pkgdesc = Command line builder for U++ applications
diff --git a/PKGBUILD b/PKGBUILD
index 9e79b460c4f1..45ae92d257c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,131 +1,78 @@
-# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+# Maintainer: Fabrizio del Tin <fdt@university.pub>
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
# Contributor: Jan Dolinar <dolik.rce@gmail.com>
-pkgbase=upp-nightly
+pkgbase=upp
pkgname=(upp-nightly theide-nightly umk-nightly)
-pkgver=10611
+yearver=2020.1
+pkgver=15620
pkgrel=1
-pkgdesc="Radical and innovative multiplatform C++ framework (known as U++) — nightly build"
+pkgdesc="Radical and innovative multiplatform C++ framework (known as U++)"
arch=('any')
url="http://www.ultimatepp.org"
license=('BSD')
-depends=('gtk2' 'libnotify' 'libpng' 'gcc-libs' 'libxft' 'desktop-file-utils')
-optdepends=('libnotify: Enables compiling gtk-styled apps' 'sox: Enables playing notification sounds')
+depends=('gcc' 'make' 'zlib' 'bzip2' 'gtk3' 'libnotify' 'openssl' 'clang' 'pkgconfig' 'gdb')
+conflicts=(upp theide umk)
options=(!makeflags emptydirs !strip)
-source=("http://www.ultimatepp.org/downloads/upp-x11-src-$pkgver.tar.gz"
- 'GCC.bm'
- 'license.txt'
- 'theide.install'
- 'https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/theide.1'
- 'https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/umk.1'
- 'https://raw.githubusercontent.com/ultimatepp/mirror/master/uppbox/lpbuild2/mkfile')
-md5sums=('SKIP'
- 'a1b57c2231b6b0fa8070941fa4accf72'
- 'b214709f096e4f50d61f50988359241e'
- '204e9ece27294b4b73cb3a31f0474d8d'
- 'b21415926edc5f18efaec625f6135556'
- 'b56d54a9d5d722bb32633a06675fbeb6'
- '9ad99eb6ead298341b6698e505067d7c')
+source=("https://www.ultimatepp.org/downloads/upp-posix-$pkgver.tar.xz")
-# uncomment this to true to build theide with simpler GUI (with no GTK dependecies)
-#USE_NOGTK=false
+prepare() {
+ cd "$srcdir/upp"
+ ./configure
+ make -f umkMakefile -j 4
+}
build() {
- cd "$srcdir/upp-x11-src-$pkgver"
-
- FLAGS="GCC GUI MT STACKTRACE"
- USE_NOGTK="${USE_NOGTK:-false}"
- if [ "$USE_NOGTK" == "true" ]; then
- SUFFIX="-nogtk"
- FLAGS="$FLAGS NOGTK"
- fi
-
- # set the version string
- echo "#define IDE_VERSION \"$pkgver-Arch-$CARCH-$SUFFIX\"" > "uppsrc/ide/version.h"
-
- # build
- msg2 "Building umk..."
- make -f "$srcdir/mkfile" PKG=umk FLAGS="GCC STACKTRACE" NESTS="uppsrc" TIME= COLOR=0 USEMAINCFG=0 JOBS=5 ECHO=0 TARGET="$srcdir/umk"
-
- msg2 "Building theide..."
- make -f "$srcdir/mkfile" PKG=ide FLAGS="$FLAGS" NESTS="uppsrc" TIME= COLOR=0 USEMAINCFG=0 JOBS=5 ECHO=0 TARGET="$srcdir/theide"
+ cd "$srcdir/upp"
+ UMK="./umk"
+ $UMK ./uppsrc ide CLANG -brs ./theide
+ $UMK ./uppsrc umk CLANG -brs ./umk
}
package_theide-nightly(){
# theide specific settings
- pkgdesc="Modern IDE designed for developping large U++/C++ applications — nightly build"
- arch=('i686' 'x86_64')
- conflicts=('theide')
- provides=('theide')
- if [ "$USE_NOGTK" = true ]; then
- depends=('libpng' 'gcc-libs' 'libxft' 'libxinerama' 'desktop-file-utils')
- optdepends=('sox: Enables notification sounds')
- else
- depends=('gtk2' 'libnotify' 'desktop-file-utils')
- optdepends=('sox: Enables notification sounds')
- fi
- options=(!makeflags emptydirs)
- install='theide.install'
-
- # license
- install -D "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ pkgdesc="Modern IDE designed for developing large U++/C++ applications"
# man pages
- install -D "$srcdir/theide.1" "$pkgdir/usr/share/man/man1/theide.1"
+ install -D "$srcdir/upp/uppsrc/ide/theide.1" "$pkgdir/usr/share/man/man1/theide.1"
# desktop entry
- install -D "$srcdir/upp-x11-src-$pkgver/uppsrc/ide/theide.desktop" "$pkgdir/usr/share/applications/theide.desktop"
+ install -D "$srcdir/upp/uppsrc/ide/theide.desktop" "$pkgdir/usr/share/applications/theide.desktop"
# icon
- install -D "$srcdir/upp-x11-src-$pkgver/uppsrc/ide/theide-48.png" "$pkgdir/usr/share/pixmaps/theide.png"
+ install -D "$srcdir/upp/uppsrc/ide/theide-48.png" "$pkgdir/usr/share/pixmaps/theide.png"
# fix permissions
find "$pkgdir/usr/" -print0 | xargs -0 chown root:root
find "$pkgdir/usr/" -type f -print0 | xargs -0 chmod 644
find "$pkgdir/usr/" -type d -print0 | xargs -0 chmod 755
# install applications
- install -D "$srcdir/theide" "$pkgdir/usr/bin/theide"
+ install -D "$srcdir/upp/theide" "$pkgdir/usr/bin/theide"
}
package_umk-nightly(){
- # theide specific settings
- pkgdesc="Command line builder for U++ applications — nightly build"
- arch=('i686' 'x86_64')
- conflicts=('umk')
- provides=('umk')
- depends=('gcc-libs' 'desktop-file-utils')
- options=(!makeflags emptydirs)
-
- # license
- install -D "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ # umk specific settings
+ pkgdesc="Command line builder for U++ applications"
# man pages
- install -D "$srcdir/umk.1" "$pkgdir/usr/share/man/man1/umk.1"
+ install -D "$srcdir/upp/uppsrc/umk/umk.1" "$pkgdir/usr/share/man/man1/umk.1"
# fix permissions
find "$pkgdir/usr/" -print0 | xargs -0 chown root:root
find "$pkgdir/usr/" -type f -print0 | xargs -0 chmod 644
find "$pkgdir/usr/" -type d -print0 | xargs -0 chmod 755
# install applications
- install -D "$srcdir/umk" "$pkgdir/usr/bin/umk"
+ install -D "$srcdir/upp/umk" "$pkgdir/usr/bin/umk"
}
package_upp-nightly() {
- pkgdesc="Radical and innovative multiplatform C++ framework (known as U++) — nightly build"
- arch=('any')
+ # upp specific settings
+ pkgdesc="Radical and innovative multiplatform C++ framework (known as U++)"
depends=('theide-nightly')
- conflicts=('upp')
- provides=('upp')
- optdepends=('libnotify: Enables compiling gtk-styled apps')
- options=(emptydirs !strip)
#copy source files
mkdir -p "$pkgdir/usr/share/upp"
msg2 "Moving the source codes..."
- cp -r "$srcdir/upp-x11-src-$pkgver/"{bazaar,examples,reference,tutorial,uppsrc} "$pkgdir/usr/share/upp/"
+ cp -r "$srcdir/upp/"{bazaar,examples,reference,tutorial,uppsrc} "$pkgdir/usr/share/upp/"
echo "#define IDE_VERSION \"$pkgver-Arch\"" > "$pkgdir/usr/share/upp/uppsrc/ide/version.h"
- msg2 "Copying additional files..."
- #license
- mkdir -p "$pkgdir/usr/share/licenses/upp"
- cp "$srcdir/license.txt" "$pkgdir/usr/share/licenses/upp"
- #build method
- cp "$srcdir/GCC.bm" "$pkgdir/usr/share/upp"
#fix permissions
msg2 "Setting permissions..."
find "$pkgdir/usr/" -print0 | xargs -0 chown root:root
find "$pkgdir/usr/" -type f -print0 | xargs -0 chmod 644
find "$pkgdir/usr/" -type d -print0 | xargs -0 chmod 755
}
+
+md5sums=('6ca4ff0e5aef7ed29f89304718eb5f09')