summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarshit Shah2018-03-10 12:36:06 +0100
committerDarshit Shah2018-03-10 12:36:06 +0100
commit1269af817cdf51c7b84d20131a9a3787c222d71a (patch)
tree1183a2af357553924879be0b00b510c39eff8804
downloadaur-1269af817cdf51c7b84d20131a9a3787c222d71a.tar.gz
New package git-recent-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e40f3187cbd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = git-recent-git
+ pkgdesc = See your latest local git branches, formatted real fancy
+ pkgver = 1.0.4.r0.g89e81a1
+ pkgrel = 1
+ url = https://github.com/paulirish/git-recent
+ arch = any
+ license = MIT
+ provides = git-recent
+ conflicts = git-recent
+ source = git+https://github.com/paulirish/git-recent.git
+ sha384sums = SKIP
+
+pkgname = git-recent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7964c4a4595f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Darshit Shah <darnir@gmail.com>
+
+_pkgname=git-recent
+pkgname=${_pkgname}-git
+pkgver=1.0.4.r0.g89e81a1
+pkgrel=1
+pkgdesc="See your latest local git branches, formatted real fancy"
+arch=(any)
+url="https://github.com/paulirish/git-recent"
+license=('MIT')
+provides=('git-recent')
+conflicts=('git-recent')
+source=("git+${url}.git")
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --always --tags --long | sed 's/^v//; s/-/.r/; s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 'git-recent' "${pkgdir}/usr/bin/git-recent"
+}