summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2015-06-08 01:17:43 -0700
committerTyler Veness2015-06-08 01:43:33 -0700
commit127a457e189161787e16e82fc507527ff8df50aa (patch)
treefbf16022535e298213b299c637a62291b70bca0b
downloadaur-127a457e189161787e16e82fc507527ff8df50aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..019e3465a202
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 4.2.0
+# Tue Jan 6 00:31:49 UTC 2015
+pkgbase = arm-frc-linux-gnueabi-eglibc
+ pkgdesc = Embedded GNU C Library (arm-frc-linux-gnueabi)
+ pkgver = 2.17
+ pkgrel = 2
+ url = http://www.eglibc.org
+ arch = any
+ groups = frc-2015
+ license = GPL
+ depends = arm-frc-linux-gnueabi-linux-api-headers
+ options = !strip
+ options = staticlibs
+ options = !emptydirs
+ source = http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libc6_2.17-r4_armv7a-vfp-neon.ipk
+ source = http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libc6-dev_2.17-r4_armv7a-vfp-neon.ipk
+ source = http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libcidn1_2.17-r4_armv7a-vfp-neon.ipk
+ source = http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libthread-db1_2.17-r4_armv7a-vfp-neon.ipk
+ source = http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/eglibc-extra-nss_2.17-r4_armv7a-vfp-neon.ipk
+ md5sums = 8c02625eb360fdf5b4de64265d5be5ce
+ md5sums = 1b1af5fa61c80d08a85efb59db550795
+ md5sums = 530e52baa9ead19ee03ef4c1eea10508
+ md5sums = 7443d9118a024f1955cfc9fa60322f22
+ md5sums = f3a6a47aacbbe69667b3b20a3a69593f
+
+pkgname = arm-frc-linux-gnueabi-eglibc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee2731bb7910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tyler Veness <calcmogul at gmail dot com>
+
+_target="arm-frc-linux-gnueabi"
+pkgname=${_target}-eglibc
+pkgver=2.17
+_basever=2.17-r4
+pkgrel=2
+pkgdesc="Embedded GNU C Library (${_target})"
+arch=(any)
+url="http://www.eglibc.org"
+curl="http://www.eglibc.org"
+license=('GPL')
+groups=('frc-2015')
+depends=("${_target}-linux-api-headers")
+options=(!strip 'staticlibs' '!emptydirs')
+source=("http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libc6_${_basever}_armv7a-vfp-neon.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libc6-dev_${_basever}_armv7a-vfp-neon.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libcidn1_${_basever}_armv7a-vfp-neon.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/libthread-db1_${_basever}_armv7a-vfp-neon.ipk"
+ "http://download.ni.com/ni-linux-rt/feeds/2014/arm/armv7a-vfp-neon/eglibc-extra-nss_${_basever}_armv7a-vfp-neon.ipk")
+md5sums=('8c02625eb360fdf5b4de64265d5be5ce'
+ '1b1af5fa61c80d08a85efb59db550795'
+ '530e52baa9ead19ee03ef4c1eea10508'
+ '7443d9118a024f1955cfc9fa60322f22'
+ 'f3a6a47aacbbe69667b3b20a3a69593f')
+
+package() {
+ cd "${srcdir}"
+ for file in *.ipk; do
+ ar x $file
+ tar xf data.tar.gz
+ done
+
+ mkdir -p ${pkgdir}/usr/${_target}
+ rm -rf lib/eglibc
+ find . \( -name .install -o -name ..install.cmd \) -delete
+ cp -r lib ${pkgdir}/usr/${_target}
+ cp -r usr ${pkgdir}/usr/${_target}
+}