summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-06-15 11:37:00 +0200
committerkleintux2022-06-15 11:37:00 +0200
commit1281d495d11713b2703e8c6284ff87d6f9702015 (patch)
tree121452f2784ad3347322538996c268f0d222f658
parent81a1767305b5b1e7c7867a22b490d2a3bf563f38 (diff)
downloadaur-1281d495d11713b2703e8c6284ff87d6f9702015.tar.gz
adopted. added patches for compiling
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--patch1.diff10
-rw-r--r--patch2.diff10
4 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 715cfe9e9922..7c0d405f57b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = floatybox
pkgdesc = Float your way through perilous terrain in this endless side-scoller game
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://octobanana.com/software/floatybox
arch = x86_64
license = MIT
@@ -9,7 +9,10 @@ pkgbase = floatybox
makedepends = cmake
depends = boost-libs
source = floatybox-0.1.0.tar.gz::https://github.com/octobanana/floatybox/archive/0.1.0.tar.gz
+ source = patch1.diff
+ source = patch2.diff
sha256sums = 1949018c82ab3a5ee66c474c850614133f52c134ed04aa133d4841d46ccc4718
+ sha256sums = 19ae5f96af26537f87db7fb21f62a98979a2a1356ae9434f599ade0ae7aaec14
+ sha256sums = cb8034c84ddbdbe80ff49395fda10d540227ae7d5c31469393ab63d11828fdeb
pkgname = floatybox
-
diff --git a/PKGBUILD b/PKGBUILD
index 0408b9538a63..c8679f619306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname='floatybox'
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Float your way through perilous terrain in this endless side-scoller game'
arch=('x86_64')
url='https://octobanana.com/software/floatybox'
@@ -10,8 +11,18 @@ _url_source='https://github.com/octobanana/floatybox'
license=('MIT')
depends=('boost-libs')
makedepends=('boost' 'cmake')
-source=("${pkgname}-${pkgver}.tar.gz::${_url_source}/archive/${pkgver}.tar.gz")
-sha256sums=('1949018c82ab3a5ee66c474c850614133f52c134ed04aa133d4841d46ccc4718')
+source=("${pkgname}-${pkgver}.tar.gz::${_url_source}/archive/${pkgver}.tar.gz"
+ "patch1.diff"
+ "patch2.diff")
+sha256sums=('1949018c82ab3a5ee66c474c850614133f52c134ed04aa133d4841d46ccc4718'
+ '19ae5f96af26537f87db7fb21f62a98979a2a1356ae9434f599ade0ae7aaec14'
+ 'cb8034c84ddbdbe80ff49395fda10d540227ae7d5c31469393ab63d11828fdeb')
+
+prepare() {
+ cd "${pkgname}-${pkgver}/src/app/"
+ patch <${startdir}/patch1.diff
+ patch <${startdir}/patch2.diff
+}
build() {
export CFLAGS+=" ${CPPFLAGS}"
diff --git a/patch1.diff b/patch1.diff
new file mode 100644
index 000000000000..f87160dae139
--- /dev/null
+++ b/patch1.diff
@@ -0,0 +1,10 @@
+--- window.cc_org 2022-06-15 11:18:57.176710590 +0200
++++ window.cc 2022-06-15 11:20:06.598793545 +0200
+@@ -72,6 +72,7 @@
+ #include <sstream>
+ #include <algorithm>
+ #include <functional>
++#include <optional>
+ #include <unordered_map>
+
+ Buffer::Buffer(Size const size, Cell const& cell) {
diff --git a/patch2.diff b/patch2.diff
new file mode 100644
index 000000000000..99429b20254c
--- /dev/null
+++ b/patch2.diff
@@ -0,0 +1,10 @@
+--- window.hh_org 2022-06-15 11:26:06.696263156 +0200
++++ window.hh 2022-06-15 11:26:18.923296588 +0200
+@@ -72,6 +72,7 @@
+ #include <sstream>
+ #include <algorithm>
+ #include <functional>
++#include <optional>
+ #include <unordered_map>
+
+ namespace aec = OB::Term::ANSI_Escape_Codes;