summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaolo2020-02-24 23:23:46 +0000
committerPaolo2020-02-24 23:23:46 +0000
commit1284c7b5f05314172dda0b605e58f70a7c4899aa (patch)
tree8ccc23a346fb82f582073b1cee28d50ee5f473e4
downloadaur-1284c7b5f05314172dda0b605e58f70a7c4899aa.tar.gz
v0.3 - initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
-rw-r--r--notes.md16
-rw-r--r--sayit2
5 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1807297efc51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sayit
+ pkgdesc = A text-to-speech command line tool that uses Azure Cognitive Services.
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/pviotti/sayit
+ arch = any
+ license = MIT
+ depends = dotnet-runtime
+ source = https://github.com/pviotti/sayit/releases/download/v0.3/sayit-v0.3-linux.zip
+ source = sayit
+ sha256sums = b04e5008cf9faad4c0fcefd0ba5b6c3569f6d4776422a01adfa212944f7bf427
+ sha256sums = 40563b76b7a1a667c8c5c04a9e21b4db277e2b09ce29328f3ff95caa72d5e040
+
+pkgname = sayit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..440c9f0421f3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e1c757bc301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Paolo Viotti <skypixel@gmail.com>
+
+pkgname=sayit
+pkgver=0.3
+pkgrel=1
+pkgdesc="A text-to-speech command line tool that uses Azure Cognitive Services."
+arch=('any')
+url="https://github.com/pviotti/sayit"
+license=('MIT')
+depends=('dotnet-runtime')
+source=(https://github.com/pviotti/$pkgname/releases/download/v$pkgver/$pkgname-v$pkgver-linux.zip
+ $pkgname)
+sha256sums=('b04e5008cf9faad4c0fcefd0ba5b6c3569f6d4776422a01adfa212944f7bf427'
+ '40563b76b7a1a667c8c5c04a9e21b4db277e2b09ce29328f3ff95caa72d5e040')
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/$pkgname"
+ cp -a "${srcdir}/$pkgname-v$pkgver-linux/." "${pkgdir}/usr/share/$pkgname/"
+ install -Dm755 "${srcdir}/$pkgname" "${pkgdir}/usr/bin/$pkgname"
+}
diff --git a/notes.md b/notes.md
new file mode 100644
index 000000000000..b75f878af76b
--- /dev/null
+++ b/notes.md
@@ -0,0 +1,16 @@
+# Arch Linux package maintainer notes for SayIt
+
+## AUR packages of reference
+
+ - Dotnet runtime: https://www.archlinux.org/packages/community/x86_64/dotnet-runtime/
+ - Emby server: https://www.archlinux.org/packages/community/any/emby-server/
+
+## Guides
+
+ - https://wiki.archlinux.org/index.php/PKGBUILD
+ - https://wiki.archlinux.org/index.php/makepkg
+ - https://wiki.archlinux.org/index.php/Creating_packages
+ - https://wiki.archlinux.org/index.php/.NET_Core
+ - https://wiki.archlinux.org/index.php/Arch_package_guidelines
+ - https://wiki.archlinux.org/index.php/Arch_User_Repository#Submitting_packages
+ - https://wiki.archlinux.org/index.php/.SRCINFO
diff --git a/sayit b/sayit
new file mode 100644
index 000000000000..7877d9d9dc71
--- /dev/null
+++ b/sayit
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/share/sayit/SayIt $@