summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-09 23:38:30 +0100
committerWorMzy Tykashi2015-06-09 23:38:30 +0100
commit128652c169f4afe17f61803dbd21645606fa7807 (patch)
tree3ccf20da59e2a707cb1c5803a6e84544b0b6a5f1
downloadaur-128652c169f4afe17f61803dbd21645606fa7807.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD48
-rw-r--r--gateone-git.install24
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce57730cec8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gateone-git
+ pkgdesc = Web-based terminal emulator and SSH client
+ pkgver = 1.1_r485.ga34f7e0
+ pkgrel = 1
+ url = https://github.com/liftoff/GateOne
+ install = gateone-git.install
+ arch = any
+ license = AGPL3
+ makedepends = git
+ makedepends = systemd
+ depends = python2
+ depends = python2-tornado
+ depends = python2-futures
+ depends = python2-setuptools
+ depends = python2-html5lib
+ optdepends = python2-imaging: A python module for manipulating images
+ optdepends = python2-pillow: An alternative to python2-imaging
+ optdepends = python2-pam: Only necessary if you plan to use the PAM authentication module
+ optdepends = python2-kerberos: Only necessary if you plan to use the Kerberos authentication module
+ optdepends = python2-pyopenssl: Used to generate self-signed SSL keys and certificates
+ optdepends = dtach: Allows sessions to be resumed even if Gate One is restarted
+ optdepends = python2-mutagen: Display audio metadata when reading audio files
+ options = emptydirs
+ source = git+https://github.com/liftoff/GateOne.git
+ md5sums = SKIP
+
+pkgname = gateone-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1ca9d0cace2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Ankz <ankz . kothari at gmail.com>
+# Contributor: Figue <ffigue at gmail.com>
+
+pkgname=gateone-git
+_gitname="GateOne"
+pkgver=1.1_r485.ga34f7e0
+pkgrel=1
+pkgdesc="Web-based terminal emulator and SSH client"
+arch=('any')
+url="https://github.com/liftoff/GateOne"
+license=('AGPL3')
+depends=('python2' 'python2-tornado' 'python2-futures' 'python2-setuptools' 'python2-html5lib')
+optdepends=('python2-imaging: A python module for manipulating images'
+ 'python2-pillow: An alternative to python2-imaging'
+ 'python2-pam: Only necessary if you plan to use the PAM authentication module'
+ 'python2-kerberos: Only necessary if you plan to use the Kerberos authentication module'
+ 'python2-pyopenssl: Used to generate self-signed SSL keys and certificates'
+ 'dtach: Allows sessions to be resumed even if Gate One is restarted'
+ 'python2-mutagen: Display audio metadata when reading audio files')
+# systemd needs to be in makedepends for building in clean chroot
+makedepends=('git' 'systemd')
+# we need emptydirs for the etc and var-lib folders
+options=(emptydirs)
+install=${pkgname}.install
+source=(git+"https://github.com/liftoff/GateOne.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe | sed -e 's:v::' -e 's:-:_r:' -e 's:-:.:g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --root="$pkgdir/"
+
+ # strip pkgdir reference from service file
+ sed -i "s:$pkgdir::" "$pkgdir/usr/lib/systemd/system/gateone.service"
+
+ # create empty conf dir
+ install -dm755 "$pkgdir/etc/gateone/conf.d"
+
+ # create empty run dir
+ install -dm755 "$pkgdir/var/lib/gateone"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gateone-git.install b/gateone-git.install
new file mode 100644
index 000000000000..c883204202f6
--- /dev/null
+++ b/gateone-git.install
@@ -0,0 +1,24 @@
+post_upgrade() {
+ if [[ "$2" < "1.1_r330.94454ca4-1" ]]; then
+ cat <<EOF
+IMPORTANT: As of 1.1_r330, Gate One has been relocated from /opt/gateone to
+your system's site-packages directory. The old location was left alone. You may
+now start Gate One by simply running 'gateone' (it should be in your \$PATH).
+
+Important default file locations (and their respective cli args):
+
+ --settings_dir=/etc/gateone/conf.d
+ --certificate=/etc/gateone/ssl/certificate.pem
+ --keyfile=/etc/gateone/ssl/keyfile.pem
+ --user_dir=/var/lib/gateone/users
+ --log_file_prefix=/var/log/gateone/gateone.log
+ --pid_file=/var/run/gateone.pid
+
+TIP: If you wish to preserve your old settings:
+sudo cp /opt/gateone/settings/*.conf /etc/gateone/conf.d/
+
+For more details, please see
+https://github.com/liftoff/GateOne/commit/94454ca48b47ef251e72d348e863833910569f14
+EOF
+ fi
+}