summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Genovés2018-11-29 19:59:01 +0100
committerManuel Genovés2018-11-29 19:59:01 +0100
commit1291f44f394043bd239b59ca034f0a58d7c1b713 (patch)
tree24ffbdb7d8fcd1e1b0121b96d0a8c84666fbabea
parentf9f500baf55298285d9674a4319f73e1e7fb81d7 (diff)
downloadaur-1291f44f394043bd239b59ca034f0a58d7c1b713.tar.gz
v2.1.3
-rw-r--r--PKGBUILD50
1 files changed, 37 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e313b4b68ea6..338daeda969b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,41 @@
pkgname=uberwriter
-pkgdesc="A simple Markdown editor that offers a lot of features."
-pkgver=15.05.01
-pkgrel=2
-arch=('i686' 'x86_64')
-url="http://uberwriter.wolfvollprecht.de/"
-license=('GPL')
-source=(http://ppa.launchpad.net/w-vollprecht/ppa/ubuntu/pool/main/u/uberwriter/uberwriter_$pkgver-publicubuntu4_all.deb)
-md5sums=('SKIP')
-depends=('python-gtkspellcheck' 'python-gobject' 'ttf-ubuntu-font-family' 'pandoc' 'dconf' 'desktop-file-utils' 'gnome-web-photo' 'hicolor-icon-theme' 'python' 'python-cairo' 'python-levenshtein' 'python-pyenchant' 'yelp' 'python-regex')
-# I got the above dependencies from debtap
+_pkgname=uberwriter
+pkgver=2.1.3
+pkgrel=1
+pkgdesc='A distraction free Markdown editor for GNU/Linux made with GTK+'
+arch=('any')
+url='http://uberwriter.github.io/uberwriter/'
+license=('GPL3')
+depends=('gtk3' 'pandoc' 'python-gtkspellcheck')
+makedepends=('python-setuptools')
+optdepends=('texlive-core' 'otf-fira-mono: Recommended font')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('git+https://github.com/UberWriter/uberwriter.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
package() {
- mkdir data
- tar xf data.tar.xz --directory data/
- cp -r data/* ${pkgdir}
+ cd $_pkgname
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
}
+
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+